Data and time not syncing via NTP

Running openSUSE Leap 15.0 when i go to YaST - System - Date and Time - Other Setting and click on Synchronize now i get an error saying Connection to the selected NTP server

failed. NTP is enabled in firewall and the NTP server is But if i go to Network Services - NTP Configuration, click edit on the server and click test it says that the

server is reachable and responds properly.

The same thing happens here.

As best I can tell, system time is about right. So I don’t think there’s an actual problem. Maybe the way it behaves via Yast is buggy – not sure.

Ok. Thanks.

Are you sure that, you have Dave Mill’s NTP Client enabled or, are you using the Leap 15.0 replacement: Red Hat’s “Chrony”?
[HR][/HR]I am totally uncertain as to whether the Leap 15.0 YaST is setup to use “a traditional NTP Client” or “Chrony” …
Whether or not YaST supports both NTP Clients and, whether or not YaST is capable of choosing the NTP Client which is activated is, AFAICS, totally unclear …
[HR][/HR]I can find nothing in the Release Notes related to the change of “preferred NTP Client” …
The only clues I know of are, this Forum and, the German Wikipedia entry related to openSUSE® …

I’ve raised the openSUSE Bug Report #1113694 to deal with the Release Notes issue …

I just checked in YaST - Install/Remove Software and Chrony is already installed.

Yes, but, you have to make sure that, only one is running …
Please check the systemd settings:

 > systemctl list-unit-files | grep -iE 'ntp|chron'
chrony-dnssrv@.service                                           static
chrony-wait.service                                              disabled
chronyd.service                                                  disabled
ntp-wait.service                                                 disabled
ntpd.service                                                     enabled
chrony-dnssrv@.timer                                             disabled

I will check that on Saturday and report back.

The output of

systemctl list-unit-files | grep -iE 'ntp|chron'


chrony-dnssrv@.service                                                 static   
chrony-wait.service                                                    disabled 
chronyd.service                                                        enabled  
chrony-dnssrv@.timer                                                   disabled 

There was a recent YaST patch which may, or may not, have fixed the YaST behaviour with respect to Chrony.
There’s also a recent change to the Leap 15.0 Release Notes (section 2.1.6) which now documents the change to Chrony: <>.

Worst case:

  1. Please check the content of ‘/etc/chrony.conf’ against the documentation in man (5).
  2. Use ‘chronyc’ to examine what Chrony is doing: “chronyc tracking”, “chronyc sources”, “chronyc sourcestats” and “chronyc activity” are possibly a good start to help determine what’s going on …

Ok thanks, i will check that and report back with the results.

Well everything is fine in /etc/chrony.conf and chrocyc is reporting that the system time is synchronized fine, the servers are available and reachable, so i guess the problem is with YaST and not chrony.

Thanks for the update.