darktable GIMP plugin

since some releases it seems the darktable plugin in GIMP works no more.
I am using Leap 15
I posted the same question in both darktable and GIMP dev forum but seems the problem is related to opensuse.
Does anyone experienced the same?

Yes, I’m afraid it’s not worked for a while.

gimp 2.8.22-lp150.3.8
dt 2.6.2-lp150.168.1

Neither does it work on a Tumbleweed setup.

I very seldom have reason to use the plugin, so I’ve not bothered too much to find a possible solution. Maybe others here are able to help.

Hi, welcome …

If I start

gimp --verbose

from a terminal window, I see

Initializing plug-in: '/usr/lib64/gimp/2.0/plug-ins/file-darktable/file-darktable'

and no errors. But, I’ve never used the plugin, wouldn’t know how it would work, what I would need to do to check. On TW though.

Just use GIMP’s File -> Open to open a raw image.

( If you want a quickie introduction to using GIMP’s darktable plugin this video isn’t too bad https://www.youtube.com/watch?v=kCZ_KRIZ1n0 )

I’m unsure when I last tried using the darktable plugin with GIMP…

It is in fact now working (still fails on leap 15.0, as the OP stated.)

TW 20190412
GIMP 2.10.8-2.1
darktable 2.6.2-2.1

Thank you indeed.
I opened a query also on development mailing list of both darktable and GIMP.
I am sure GIMP has been compiled with darktable support but I cannot understand if it has been compiled with Lua support.
The reason is the darktable plugin uses Lua in order to manage this operation and the problem happens when Lua should be invoked…

As I wrote in post #5 the darktable plugin is now working in Tumbleweed…

What you could try would be to use the Tumbleweed version of GIMP.

Don’t add the Tumbleweed repository though, as that will cause future problems.

Create a directory, let’s say “local_repository” for example.

Download the TW version of GIMP:

and copy to your “local_repository”

Use YaST2 Software Management (Configuration → Repositories - Add) to add a new “Local Directory…” repository of type “Plain rpm”.

Then install from there, (use the “Versions” tab to select the version to install).

Sorry, forgot to mention … you’ll also need these:


What version of GIMP are you currently using?

Leap 15.0 has 2.10.4-lp150.3.1 in the “graphics” repo https://download.opensuse.org/repositories/graphics/openSUSE_Leap_15.0

I haven’t tried that so don’t know if it works, it’s still a lower minor version than those of TW, so maybe not … don’t know.

Hi, if you are installing a standalone .rpm, is it beneficiary to do it via local repository/YaST?

Personal preference…

For testing purposes as in this case, if the package comes from a different (distribution) repository, that’s the way I prefer.

I feel it’s much easier to control… you only need to look around the forum to see cases of “mixed” repositories causing havoc.

One could of course install via rpm if that’s your thing…

rpm -Uhv package_file.rpm

will upgrade a package with verbose output, if the package has not been installed, this command installs the package.

The gimp 2.10.8 from tumbleweed doesn’t work in leap 15 due to a large number of dependency issues.
I tried it a week ago. The way to go is the gimp 2.10.4 from the leap 15 graphic repo.

OK… Thanks for that, I hadn’t tried it.

So is the darktable plugin present and working with 2.10.4 ? I’ll have to give it a try later today if I’ve time.

You can use YaST to install RPMs from another distro version…
But you need to do one thing to avoid catastrophic problems (pulling in unwanted packages, possibly changing to the alien distro version)

On the first screen after you provide root permissions,
One or more repositories where the package comes from will be offered to be added, and the the default is to add them.
You must uncheck these repositories to avoid adding them to your system.

Continue to install.
The advantage of using YaST while accessing (but not adding) the repositories is that any dependencies should be added and installed automatically, don’t have to be installed manually.


Please, don’t suggest adding other distro version packages. It will beyond doubt lead to trouble. If not now, then some day in the future. The best way to go would be to branch the package in OBS, and have it built in your own repo for the appropriate distro version repos. Not only easier ( after the first success ), also safer.

OK… Finally I think we have the definitive requirements for darktable/gimp from post #19 by “houz” here:


So it would seem that 2.10.4-lp150.3.1 in the leap “graphics” repo ( https://download.opensuse.org/repositories/graphics/openSUSE_Leap_15.0 ) should work. Unfortunately I don’t have time to try this right now…

The only reason why I posted what you see is that installing a package from a different openSUSE version has already been the subject of most of the posts in this thread. So, if it’s going to be done, I posted how to do it properly to avoid the catastrophe many other Forum threads have been about.


In your first post, you mentioned installing packages from another distro and on your second one, from a different OpenSUSE version. I think those two sounds very different to another person reading it. In all fairness, if this is matter of installing a .rpm package, isn’t it easiest to just do it via

rpm -Uhv package_file.rpm

as been mentioned by Tannington?.

Skinning cats springs to mind…

The “best” method to install packages(s) depends on what the package(s) are, where they came from, what dependencies they may have, and of course one’s own level of understanding.

But we are drifting further off the OP’s original topic now…

You will have more control using yast or yast2.
Example, you can create a local folder as a local
repo for yast on the target rpm file etc.
Yast is a powerful tool.

“A different distro” and “different version” are both covered the same here, the potential danger is the same for either to happen.
So “different distro” might for instance cover LEAP vs Tumbleweed vs even Fedora if you pulled in a package from a Fedora repo.
A “different version” might for instance cover 15.0 vs 15.1 vs 42.3, 13.1 or similar.

Your rpm command about the same as doing “zypper install,” both will do the same thing.
Comparing your rpm command (and zypper) installing an RPM that’s not in a repo to using the YaST Software Manager will be the same only if the rpm has no dependencies, if the rpm wants to pull in other packages, your command won’t have access to the repository the rpm came from (because you’re pointing to a file location on your machine that the remote repository).
By using the YaST Software Manager, dependency packages can be found in the remote repository for that install session.
But, as I tried to emphasize it’s **very **important not to accept the default “checked” check boxes that add the repos to your system, if those repositories are made a part of your system permanently you could experience a catastrophic alteration to your system.