Dark Screen with Virtualbox after upgrade?

Getting a black screen when using Virtualbox on OSX, every time I do an update.
I see the Grub menu, I can see the login window, type my info in and it goes black.
But I can tell it’s working. My VM is on an external drive and I see the activity light flashing.

My workaround: Either press Ctrl-Alt-del or insert it with the Vbox menu.
Wait a few seconds, press Enter. It logs you out.
The login screen shows up full screen. Log back in.
I see the light bulb flash screen and my Desktop loads.
And then it will load every time after.
Works every time for me.

Seems to be a long time issue with Virtualbox and OpenSuse because when I was researching I found plenty of issues with that going back.
I had tried re-installing from an upgrade DVD, tried adding nomodeset to the startup command, and going back a kernel, until I stumbled across the logout/login thing by accident.

Hope that helps someone!

THANKS A LOT for your workaround, I was desperate because exactly THIS happened to me since September 1st after a Leap 15.2 update, I did “snapper rollback” and I already had planned to refuse any further update on the Leap Guest. And now, YOUR SOLUTION WORKED !!! That’s the strength of being a community … Thanks again! :slight_smile:

Do not do a CTL-ALT-DEL.
Besides the disk activity light flashing, you should be able to pres the ESC key to view your real time system activity on screen to verify it’s not locked, your system is still working and you shouldn’t interrupt it.