Dancing windows driving me nuts!


Does anyone know how to turn off the effect where you go into the top right hand corner of the screen and it shrinks and moves all the windows so they sit next to each other? It’s driving me nuts, every time I go to maximise/minimise/close a window they all move, I have to click on it, then try again or right click close at the bottom.

Turning off desktop effects does remove it, but i want to keep the rest of the effects! I have been through the compiz options turning them off one by one but nothing seems to help, I’m clearly overlooking something (like what the effect is called).

Hi there,

In the more recent versions the best way to turn this off is to open system settings, go to desktop → screen edges and disable it from there.

Desktop effects is doing this
System Settings > Desktop > Desktop > Screen Edges
Or just disable all effects

Yay, thanks! It was in desktop effects/edges (11.2). I hadn’t realised you were to click on the individual bars and cancel the effect there.


I find it very useful (expose all windows) but I usually set it to the top left corner. You rarely go there otherwise,