Damaged my 13.2 Desktop

Hello, i am running 13.2 on Asus P42J (fresh install from DVD still 32-bit EXT4- KDE4 -dual boot with Win7 ).About 2 weeks ago - well in advance of the latest kernel-update- i played a bit too much with the desktop: the result is: after rebooting a black screen with the cursor showing being manoevriable by the touchpad. Some details: when choosing o.S 13.2 the green screen appears,thereafter the linux greeter, after typing my password the green screen continues, the 5 icons within the box appear and after some seconds the screen is getting black with the cursor only .After some seconds again the sound normally announcing the completion of the desktop can be heard. To be able to use the machine i am using Ice WM, which turned out to be very comfortable: nothing has been lost : yast, internet connctions, ssh exchange to my other 2 laptops But one day i might want to get back the complete-KDE4 screen. I guess just to make a fresh install with home partition unchanged would result in a black screen, because the inputs which led to the mess have been stored as personal settings.- Does someone knows a way to repair the KDE screen? Thanks ebkr

Sounds like plasma-desktop is crashing on startup.

You could try to create a new user account (in YaST->Security and Users->User and Group Management) and test whether it works there, or start fresh with your existing account by removing/renaming the ~/.kde4/ folder to reset the configuration (note that this contains more than just the configuration, so you might lose data if you remove it).

If it doesn’t work with a fresh config either, it is probably an installation issue.
Try running “plasma-shell” in a terminal (inside IceWM e.g., or start Konsole/xterm via Alt+F2 which should still work) and check/post the output (the last lines should suffice).

It might also be caused by a graphics driver issue, so try booting to recovery mode (“Advanced Options” in the boot menu).

thanks, wolfi 323 for your reply. It will take a while till i will have tried.Will keep you informed. ebkr

Hellö, I entered into ICE WM terminal:1
. it showed about 143 lines, the meaning of which I am not able to understand. 2.
which produced a black screen, however at the lower edge the p a nel showed with all icons as I had them before my crash. Clicking the Icon New Activities in the upper right corner the toolbox enabled me to complete Since the desktopicons had been deleted by the crash, I had to activate them by the ckick-off starter. After rebooting and choosing plasma-destop in the greeter box, the kde-desktop popped up again. Thank You very much for Your help Ebkr

Sorry, in the previous thread I used brackets when naming the entries into the IceVM terminal, so they have been omitted. Here they are: 1. plasma-shell 2. plasma-desktop Ebkr

You mean you ran those two commands in the terminal?
plasma-shell does not exist at all (even in Plasma5 it is called “plasmashell” without a ‘-’), I don’t understand how you could get 143 lines of output from that… :wink:

Anyway, IIUYC, your problems are solved, right?

The problems are solved. You are right, the output was not from plasma-shell, but from plasma-desktop with 124 lines.