D-Link DWL-G132 usb - supposed to work

I couldn’t configure my pci card at all so I went to the sites with compatibility info, and got the above D-Link USB dongle with a cradle. It worked straight away with WinXP.

For some reason I can’t get ndiswrapper to install the driver. It says something about driver conflict. Does this mean I should remove the driver for the pci card, or is it likely to be that I have tried to install the wrong one (there were three lots on the CD for windows versions.) Would it matter if I tried to install all of them?

I like a challenge but this will soon be frustrating. It took ages to get the Dlink - had to cancel an unfulfilled order and get it from somewhere else. It only arrived today.

I have this card and haven’t had a problem with it. These are the files I took off the CD:
A5AGU9x.sys
A5AGU.sys
ar5523.bin
DWLInst.dll
DWLNdi.dll
NetA5AGU.cat
NetA5AGU.inf

Also, please look in directory /etc/ndiswrapper and tell us what subdirectories exist there if any. They will show if you’ve installed ndiswrapper previously and what.

Also, have you tried to install madwifi or any other non-ndiswrapper drivers?

Swerdna

Well immediately I see that I don’t have all the same driver files.
I don’t have A5AGU9x.sys or DWLNdi.dll
I have all the others plus a folder called x86 which contains agux86.cat, agux86.inf and agux86.sys.
I also have DWLAB.dat but I guess that one doesn’t really count.

I looked in /etc/ndiswrapper and there was folder called aguxx86 which contains 6 conf files (didn’t think the detail was important?) plus agux86.inf and agux86.sys.
In addition to this folder there was also: a5agu.sys and agux86.sys

In the past I tried to use ndiswrapper for a PCI card and also tried using debian for same purpose. Theh pci card is listed in Yast Network devices/cards, but fails to work. So I got the D-Link to see if I would have better luck.

Thanks

sorry the folder was agux86 NOT aguxx86 - typo

Well that’s a puzzle. I wonder if you’ve got the wrong drivers or if the chipset has changed. So two questions:

Q1: What’s the hardware version number on the silver tag on the back of the dongle? Mine says H/W Ver: A3
Q2: What’s the USB ID number of your dongle?
You discover the USB ID by entering the command lsusb in a console. This is what I get for the dongle:

Bus 001 Device 007: ID 2001:3a03 D-Link Corp. [hex]

What do you get?

Hi,

I too am having trouble with DWL-G132. I have the a2 version of the dongle: eg 2001:3a02.

I have tried every possible permutation of inputs. Using the 1.02 version of the XP driver on a clean installation of openSUSE 11.1 with the ndiswrapper from the openSUSE 11.1 repositories. I have tried installing just the neta5agu.inf driver, then just the athmwfdl.inf, finally both.

I have noticed that if I (hot) un-plug and plugin the usb drivers think that the dongle is the a3 version, eg 2001:3a03. When this occurs, the command ndiswrapper -l shows that both drivers are present, but there is no hardware. The lsusb command shows something like:
Bus 002 Device 005: ID 2001:3a03 D-Link Corp. (no firmware)

I have created links to the 2001:3a02.conf file for both neta5agu and the other driver (eg ln -T 2001:3a02.conf 2001:3a03.conf -s). This succeeds in allowing ndiswrapper to recognize the device, but none of the leds glow and there is no wireless connection. I have verified that ndiswrapper is loaded (there is a directory called ndiswrapper in /etc/modprobe).

The funny thing is that I was able to use this dongle on the same computer running 10.3. To the best of my recollection it was not this difficult to get it running then.

I would appreciate any help anyone might have. I am beyond my wit’s end…

Many thanks!

-Greg