D-Link DWA-510 Opensuse Linux Installation

Hi, guys, I thought if I change a wireless card everything will be OK. But, here is more questions to ask…

I am a new Linux user, so please help…:slight_smile:

I’ve tried to follow following driver instructions.


Build Instructions:


1> $tar -xvzf RT61_Linux_STA_Drv_x.x.x.x.tar.gz

go to "./RT61_Linux_STA_Drv_x.x.x.x/Module" directory.

2> $cp Makefile.4 ./Makefile # [kernel 2.4]


$cp Makefile.6 ./Makefile # [kernel 2.6]


$cp Makefile.RTL865x ./Makefile # big endian platform

3> [kernel 2.4]

$chmod 755 Configure

$make config         # config build linux os version

4> $make all # compile driver source code

4.1> $make install

5> $cp rt2561.bin /etc/Wireless/RT61STA/ # copy firmware

$cp rt2561s.bin /etc/Wireless/RT61STA/

$cp rt2661.bin /etc/Wireless/RT61STA/

6> $dos2unix rt61sta.dat

$cp rt61sta.dat  /etc/Wireless/RT61STA/rt61sta.dat       

# !!!check if it is a binary file before loading !!!  

7> $load

#[kernel 2.4]

#    $/sbin/insmod rt61.o

#    $/sbin/ifconfig ra0 inet YOUR_IP up


#[kernel 2.6]

#    $/sbin/insmod rt61.ko

#    $/sbin/ifconfig ra0 inet YOUR_IP up

Note: Script functionality:

load load module to kernel

unload unload module from kernel

Configure retrieve linux version

I did the first two. Because my system is OpenSUSE 11.0 I skiped step3. I tried to run : make all , but it is not a command.

Can anyone tell me what to do?


Here are the files I have.

assoc.c Makefile.4 rt2561.bin rtmp_main.c
auth.c Makefile.6 rt2561s.bin rtmp_task.c
auth_rsp.c Makefile.RTL865x rt2661.bin rtmp_tkip.c
config.mk md5.c rt2661.h rtmp_type.h
Configure md5.h rt61sta.dat rtmp_wep.c
connect.c mlme.c rt_config.h sanity.c
eeprom.c mlme.h rtmp_data.c STA_iwpriv_ATE_usage.txt
ifcfg-ra0 Module.symvers rtmp_def.h sync.c
iwpriv_usage.txt oid.h rtmp.h unload
load README rtmp_info.c wpa.c
Makefile ReleaseNote rtmp_init.c wpa.h

Here are the files I have.

assoc.c----------------- Makefile.4-------------------------------------- rt2561.bin---------------------------------- rtmp_main.c
auth.c-------------------- Makefile.6-------------------------------------- rt2561s.bin-------------------------------- rtmp_task.c
auth_rsp.c-------------- Makefile.RTL865x ---------------------------rt2661.bin---------------------------------- rtmp_tkip.c
config.mk ---------------md5.c-------------------------------------------- rt2661.h------------------------------------ rtmp_type.h
Configure -------------- md5.h --------------------------------------------rt61sta.dat--------------------------------- rtmp_wep.c
connect.c ---------------mlme.c------------------------------------------- rt_config.h ---------------------------------sanity.c
eeprom.c -------------- mlme.h------------------------------------------ rtmp_data.c --------------------------------STA_iwpriv_ATE_usage.txt
ifcfg-ra0 -----------------Module.symvers----------------------------- rtmp_def.h ---------------------------------- sync.c
iwpriv_usage.txt ------oid.h--------------------------------------------- rtmp.h--------------------------------------- unload
load---------------------- README-------------------------------------- rtmp_info.c-------------------------------- wpa.c
Makefile ---------------- ReleaseNote --------------------------------- rtmp_init.c ---------------------------------wpa.h

This is the PCI list.

01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600 GT (rev a1)
02:00.0 Ethernet controller: Attansic Technology Corp. L1 Gigabit Ethernet Adapter (rev b0)
03:00.0 IDE interface: Marvell Technology Group Ltd. 88SE6121 SATA II Controller (rev b2)
05:01.0 Network controller: RaLink RT2561/RT61 rev B 802.11g

I’m afraid this is not the simplest way of doing things in OpenSuSE (actually it may well be the hardest). I’d suggest you run the lspci|grep 802.11 command in a shell to get the name of the wireless chipset. Armed with that info I’d hop over to https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsDlink#PCI (or to the SuSE hardware compatibility list) and browse around to see which of the listed drivers applies for my network card and follow the related instructions. In all probability, you’ll need the ndiswrapper wrapper + the Windows drivers to make it work. If that should be the case, you just install ndiswrapper in YaST/Software and get a set of working Windows drivers for your card. Be as it may, I don’t think you need to compile anything.
Greetz & good luck!

This is the driver I download from D-Link website.

The installation steps are from the readme file.

:stuck_out_tongue: I am not sure what to do. The reason I use this card is that I want to avoid use Ndiswrapper.

So, maybe I should run : make instead of make all.
Then run: make install

I don’t know. I am only using applications running on Linux.

Just downloaded the drivers to have a look & play around with them.When you extracted the files,did you see 3 .bin files ? if so, copy them to /lib/firmware & re-boot. See if that helps


Thanks Andy, I am browsing via wireless now. I did what exactly you told me to do. It works so good.;)rotfl!

Thanks again!!!

Cool, glad you got it working,Now Enjoy :slight_smile: