D-Link DVA-G3670B printer server

Hi,

I’ve just bought this piece of machinery… and can’t get it to print. I have a D-Link DVA-G3670B router with printer server which I set up with a printer name ‘brother’. I have a Brother HL-2040 laser printer which is connected to the router. I am running openSUSE 11.2 and KDE4. Now, the printer works (sometimes), it sometimes spontaneously prints test pages from the router (eg. if I turn printer off and then on). And so the router works with the printer by itself. The question is what can I do to make it print from my computer?

  1. I have Brother driver installed
  2. I tried YAST setup
  3. I tried CUPS server setup
  4. I tried
    http://192.168.1.1:631/printers/brother
    http://192.168.1.1:631/brother
    http://192.168.1.1/printers/brother
    http://192.168.1.1/brother

then I tried the above variations with ipp://, ldp:// and anything imaginable in between. It simply won’t print! But one time though, it did print one page and that was it. It’s a total mystery for me. Please help anyone, I’d really appreciate it. Thank you.

I do not know if this of use to you as I do not have this device. I have a similar setup though through a Fritz!box 7170, and I would imagine that the setup requirements are similar.

My solution was to setup via cups i.e. http://localhost:631, choose ipp printing and put the Device URI: as socket://192.168.178.1:9100 where 192.168.178.1 is the url of the fritzbox, and 9100 is the standard port.

Hi,

You can use the traditional Unix server (LPR)
Go to yast hardware printer print via network and use the connection wizard and hightlight the traditional unix server (LPR) type the ip of your router and the Queue is lp and test your connection, if you have positive result during the test proceed with the configuration.

I’ve just confirmed it’s a Linux problem. I’ve set up a printer in Windows as http://192.168.1.1:631/printers/brother and it works perfectly well. I’ll try your ideas next with IPP socket and LRP. Thank you.

Can I suggest that you set the printer up directly to the Linux box, bypassing the print-server, to see if this is a printer problem or a server problem. Also if the router/server has an option to allow USB devices to be detected as new hardware by the operating system, so that device drivers and software can be installed, disable this function as it seems to kill the printer port. (at least it does on the Fritz)

On Sat December 12 2009 04:56 am, Dwarfer99 wrote:

>
> Can I suggest that you set the printer up directly to the Linux box,
> bypassing the print-server, to see if this is a printer problem or a
> server problem.
>
>
linuxoidoz;

There is a known problem with the brother drivers on OpenSuSE 11.2. Many have
been able to find a Foomatic driver that will work. See this thread for more
information:

http://forums.opensuse.org/hardware/64-bit/426327-64-bit-printing-brother-2040-laser.html

P. V.
“We’re all in this together, I’m pulling for you.” Red Green

I’ve tried ipp, ldp, lpr, http, cups, socket, everything. It will simply not print. Win7 and XP prints without a problem.

I haven’t tried connecting it directly to USB, I’ll do this next, but I had 11.1 2 weeks ago and it printed OK (even though it took me quite a while to make it to), 9.2 - 11.0 were no brainer to set up, but for some reason starting from version 11.1 it got harder until this 11.2 when it got impossible.

I’ve always used the brother drivers without any problems on 64 bits, I also used foomatic brother hl-2060 drivers before also without problems.

What I noticed also was

  1. if I use the Test in YAST after entering the hostname, it says ping (or something) failed, impossible to do something through port 591 (sorry don’t remember details)
  2. If I try the socket, it says the same thing about port 9100 (or so)
  3. When I print a test page through the CUPS server, it shows the page has gone but the light is yellow and nothing happens, it says the printer connected to the host
  4. I tried turning OFF the firewall - no difference.
  5. I tried foomatic and ghost (or something) drivers for brother 2060, 1240, 1260 etc. - no difference

This is the first time openSUSE is testing my patience in 3-4 years. Another thing I found was the keyboard starts sticking on my desktop, but not on a laptop. I had this problem in KDE4.0 and it was gone until now. But this is another topic.

I’ll try what they suggest in the link. Thank you.

On Sun December 13 2009 03:26 pm, linuxoidoz wrote:

>
> I’ve tried ipp, ldp, lpr, http, cups, socket, everything. It will simply
> not print. Win7 and XP prints without a problem.
>
> I haven’t tried connecting it directly to USB, I’ll do this next, but I
> had 11.1 2 weeks ago and it printed OK (even though it took me quite a
> while to make it to), 9.2 - 11.0 were no brainer to set up, but for some
> reason starting from version 11.1 it got harder until this 11.2 when it
> got impossible.
>
> I’ve always used the brother drivers without any problems on 64 bits, I
> also used foomatic brother hl-2060 drivers before also without problems.
>
>
> What I noticed also was
> 1. if I use the Test in YAST after entering the hostname, it says ping
> (or something) failed, impossible to do something through port 591
> (sorry don’t remember details)
> 2. If I try the socket, it says the same thing about port 9100 (or so)
> 3. When I print a test page through the CUPS server, it shows the page
> has gone but the light is yellow and nothing happens, it says the
> printer connected to the host
> 4. I tried turning OFF the firewall - no difference.
> 5. I tried foomatic and ghost (or something) drivers for brother 2060,
> 1240, 1260 etc. - no difference
>
> This is the first time openSUSE is testing my patience in 3-4 years.
> Another thing I found was the keyboard starts sticking on my desktop,
> but not on a laptop. I had this problem in KDE4.0 and it was gone until
> now. But this is another topic.
>
> I’ll try what they suggest in the link. Thank you.
>
>
linuxoidoz;

The problem with Brother drivers, just surfaced with 11.2. Have you tried
replacing cables just in case there is some connectivity issue? If you can
currently print from Windows, I doubt it’s an issue. You might also try to
ping the D-Link DVA-G3670B just to make sure. In a terminal window enter:


ping -c6 <DVA-IP>

My money is on a driver problem.

P. V.
“We’re all in this together, I’m pulling for you.” Red Green

We are using a d-link D1-794UP router print server and has never failed with printing using the method I mentioned on my first post.
It could be a driver problem.

If you tried my suggestion, did you put lp in the queue before you did the test. It should be there before testing.

Mine too, i’m sure it’s a driver/cups issue, I can ping the router and everything. The XP is the same machine, so it’s not the cable/hardware.

I’ve downloaded new drivers from Brother and OpenPrinting database, I’ll try them all tonight as well as the Foomatic hl-2060/1250 driver again and let you know. Thank you.

Hey, it works!!! When I tried everything I haven’t tried a combination of IPP and different driver. Well, it was item No 326 on my list of combinations. But thanks to you guys I got it working at last.

So, for those with the same problem and same hardware:

Prerequisites: make sure cups and cups-drivers are installed, don’t bother with the Brother driver. And the driver from OpenPrinting database didn’t work either.

  1. Create a printer “brother” (without inverted commas and choose any name you like) in the D-Link DVA-G3670B router (default router IP 192.168.1.1)
  2. Go to YAST -> Hardware -> Printer and add a printer with Internet Printing Protocol, i.e. IPP: “ipp://192.168.1.1:631/printers/brother” (again without inverted commas and the last word should match one you chose in the router)
  3. Select brand Brother and click Next
  4. Choose driver Brother HL-1240 Foomatic/hl-1250 (recommended)
  5. Click OK
  6. Then (I don’t know why YAST doesn’t do this the first time but…) click Edit and then go to All Options for the Current Printer and set your preferred printing settings, choose paper size and make sure Enable Printing and Accept Print Jobs are selected, you may want the Default Printer selected as well
  7. That’s it, click OK again and finish. Open a document and print, it should work now.

If this doesn’t work try another driver.

PS. The router manual says the printer should be set up as “http://192.168.1.1:631/printers/brother” and this does work in Windows. But in Linux for some reason only IPP protocol works. You can try HTTP but I’ll just leave it as is for now. Hope this helps. Thank you all.

Is there any way to attach pictures here?

On Mon December 14 2009 03:36 pm, linuxoidoz wrote:

>
> Hey, it works!!! When I tried everything I haven’t tried a combination
> of IPP and different driver. Well, it was item No 326 on my list of
> combinations. But thanks to you guys I got it working at last.
>
> So, for those with the same problem and same hardware:
>
linuxoidoz;

Thank you for posting the solution. I’m sure other users will find it
valuable. Enjoy your printer!


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

>> Is there any way to attach pictures here?
You can upload the pic to some server (try imagebam.com) and then post the link here.

Here’s a link to a YAST-Printer screen shot
http://picasaweb.google.com/linuxoid.au/MyAlbum#5415576019624990546

Well port 631 is the IPP port which is based on HTTP but has its own set of commands. So the printer manual and M$ are a little retro using the scheme HTTP with :631, because the protocol has a proper name: IPP.

Great now u can print out a screen shot when ur playing WOW.
In wow-titan you can with ur custom gear!
with great Gms & 100% of quests working, supporting 3.3.5 & cata:)
so come to WoW-Titans | Private Server and check it out how to register easy :wink:
Rodimus