D-Bus and KNetworkManager


In an attempt to remove services that I don’t use I ran through my /etc/init.d file and removed many of the daemons that I didn’t think I was using. This included the removal of my D-Bus daemons and many of their assoicated libraries, I think they are called avahi?

Now Network Manager and ifup don’t seem to want to connect me to the interent anymore. Does anybody know why this would be? Is it in fact related to the removal of my D-Bus daemons?

I’d like to avoid running daemons I don’t need (samba, cups etc…) but obviously want my system to run.

Are there some libraries that I could install to get Network Manager running without using the avahi daemon itself?



D-bus is essential for many things in the system, especially for knetworkmanager…
You shouldn’t have removed it.
Anyway, if you wish to keep some services off, so that they don’t slow down your system, just use Yast > system .
To repair the removal of the dbus startup script and other removals you accidentally made, i suggest you force the re-installation of their rpm packages with Yast .

Thank you very much, I appreciate the help.

Ok, I’m gonna have to keep asking, now have the D-Bus libs/daemon back up and running, but now I can’t get Network Manager to start.

Once I run Network Manager, the applet shows up in the Task Manager, but its Grey instead of Green, and if I right click on it it says “Network Manager is not running” and it appears ifup isn’t working either.

Anybody else have any thoughts?

Also, as a side note, since this problem arose from me trying to unistall daemons that are listed as running but I don’t use in /etc/init.d, would someone who has a pretty vanilla install of openSUSE 11.1_x64 give me a listing of the direcotry with:

ls /etc/init.d

and post it here?