Cyrillic letters in file names are not supported in console, okular, libre office, etc.

I migrated to 42.1 recently and now I have a lot of issues with cyrillic letters in file path. Dolphin shows these files correcly, but in console all cyrillic letters in filenames are replaced with question marks ("?"). If I try to open these files I recieve the message that the file does not exist and all the cyrillic letters in path in this message are replaced with “?” or other meaningless stuff:

Could not open D/Мои документы/Разное/Резюме/Рябов_Юрий.pdf

When I rename files to use latin symbols only everything works.
Tryed to google this issue but found nothing.
Please help:(

Try changing the font in each of the programs where you have problems. For example in konsole Settings>Appearance>Select font. If you have no other ideas yourself, try DejaVu Sans Mono.

Nope, that doesn’t help, as well changing the encoding…

I was able to copy and paste Cyrillic characters into konsole after I had changed the default font to DejaVu; when I added a Russian layout in System Settings>Input Devices>Keyboard>Layout I was also able to enter Лшадсщ (no idea what these characters are!) from the keyboard.

I guess the OPPs questions is now, can you:

henk@boven:~/test> touch Лшадсщ
henk@boven:~/test> ls -l Лшадсщ
-rw-r--r-- 1 henk wij 0 20 jun 09:45 Лшадсщ
henk@boven:~/test> vi Лшадсщ

Which I can on 13.1 without doing anything particular (I “stole” the file name using copy/paste from the post above).
And using Dolphin it shows correctly in the list.

The OP has complaints aboput Leap 42.1 whhich I do not have available. Thus I am afraid I can not help anymore except showing how it works in 13.1

openSUSE 13.2; Konsole Version 2.14.2 under KDE 4.14.9; Konsole Terminal Font: Bitstream Vera Sans Mono.

 > touch Лшадсщ
 > l Лшадсщ
-rw-r--r-- 1 dcu users 0 20. Jun 10:02 Лшадсщ
 > vi Лшадсщ
 > l Лшадсщ
-rw-r--r-- 1 xxx users 24 20. Jun 10:03 Лшадсщ
 > file Лшадсщ
Лшадсщ: ASCII text
 > cat Лшадсщ

 > rm Лшадсщ

Unfortunately, from the tty2 Console the default font doesn’t display the Cyrillic characters (??? displayed . . . ).
The following commands available to show/set the console (EGA/VGA) font: showconsolefont; setfont.
The ‘setfont’ man page mentions the /usr/share/kbd/consolefonts/ directory which seems to contain some Cyrillic fonts.
This URL may also help: <>

Ah, I now understand better I think.

You mean from the virtual console. I worked with a terminal emulator within KDE.

When I do this from virtual console (I tried #1 and #2), I get replacement characters (a bit small, but like white squares).

Now on a Leap 42.1 system.
As with the 13.2 system ‘/usr/share/kbd/consolefonts/’ contains fonts which are presumably Cyrillic fonts.
[HR][/HR]Either with the YaST “/etc/sysconfig Editor” or simply edit ‘/etc/sysconfig/console’ and set-up the Hardware/Console variable “CONSOLE_FONT” to a suitable value.For example on this system it’s “lat9w-16.psfu” which is the ‘lat9w-16.psfu.gz’ file in ‘/usr/share/kbd/consolefonts/’.

But, it’ll depend on who is maintaining the system. It may be preferable to handle the Virtual Terminal Cyrillic fonts issue on a per-user basis by means of the user’s shell login: ‘setfont’ if-and-only-if a Virtual Terminal.