Cyclic dependencies in systemd between network and xinetd

This is already a long-term issue in TW - xinetd.service has a cyclic dependency issue with the network service. Each time I restart one of both, network or xinetd doesn’t come up, in a random manner. No further idea what to do with this:

rkrell:~ # systemctl status xinetd.service 
● xinetd.service - Xinetd A Powerful Replacement For Inetd
   Loaded: loaded (/usr/lib/systemd/system/xinetd.service; enabled; vendor preset: disabled)
   Active: inactive (dead)


Oct 13 08:26:13 rkrell systemd[1]: xinetd.service: Breaking ordering cycle by deleting job SuSEfirewall2_init.service/start
Oct 13 08:26:13 rkrell systemd[1]: xinetd.service: Found ordering cycle on xinetd.service/start
Oct 13 08:26:13 rkrell systemd[1]: xinetd.service: Found dependency on network.target/start
Oct 13 08:26:13 rkrell systemd[1]: xinetd.service: Found dependency on NetworkManager-wait-online.service/start
Oct 13 08:26:13 rkrell systemd[1]: xinetd.service: Found dependency on NetworkManager.service/start
Oct 13 08:26:13 rkrell systemd[1]: xinetd.service: Found dependency on SuSEfirewall2_init.service/start
Oct 13 08:26:13 rkrell systemd[1]: xinetd.service: Found dependency on YaST2-Second-Stage.service/start
Oct 13 08:26:13 rkrell systemd[1]: xinetd.service: Found dependency on xinetd.service/start
Oct 13 08:26:13 rkrell systemd[1]: xinetd.service: Breaking ordering cycle by deleting job YaST2-Second-Stage.service/start
Oct 13 15:33:15 rkrell systemd[1]: xinetd.service: Unit cannot be reloaded because it is inactive.

Sometimes this causes also the network not to come up (using NetworkManager).

The problem is likely with YaST2-Second-Stage.service. Simply disable it, I doubt you actually need it.

Disabling YaST2-Second-Stage.service did indeed work around this problem.
But it is a bug, isn’t it?

Yes. Well known one :slight_smile:

Oh, sorry. I raised a bug report for this: 950504 – Cyclic dependencies in systemd between YaST2-Second-Stage and xinetd.
So feel free to mark it duplicate if there is a better one :slight_smile:

Just for the record to everyone who is concerned by this: I just read the message, that this has been fixed.

See:

Just did not arrive to Tumbleweed yet.