Custom build from suse studio|missing "initrd-" file

If you can access Suse Studio here is the link to the build
LFS Host – SUSE Gallery

Google hasn’t been friendly and neither has a search on these forums, I don’t know which man to read so a finger in the right dirrection (preferably not the middle) would be nice as far as that goes

Right now the yast live installer trips up at %84 while saving the boot loader configuration and displays a popup that says “An error occurred during initrd creation. /sbin/mkinitrd: illegal option —s”

I then press enter to acknowledge the message and the installation continues without a hitch.

When I go to boot up (no other os installed) grub says it cant find the file initrd-

If you boot the live cd again you can mount the boot partition and you’ll find a broken symlink called initrd that is looking for the missing file above.

Like I said above, if it an obvious fix, all I need is some direction, I don’t mind reading. (been doing that all day)

If you need more specifics Id be happy to supply, I’m just not sure whats relevant and don’t want to bloat the post.

On the face of it, the error looks fairly clear… An illegal option/flag was implemented during that particular step running mkinitrd, I don’t know if the “–s” is the actual illegal option or not. Additionally, the missing file seems to confirm.

So, I guess the next step is to determine why that error occurred, was it something you did or is it a default setting that’s wrong or might it simply be an error parsing a string?

Also, I suspect you might get more eyeballs on this by posting in one of the Developer forums, this forum doesn’t touch on coding too much.