Cursor disappears after changing to 1280x1024


I’m new user of Suse, I just moved from Ubuntu 9.10. After install resolution was set as 1152x864 but for my monitor 1280x1024 is good. When I changed resolution cursor disappeared. When I changed to 1024x768 cursor stays. Is there any way to remove this problem? I searched forums and didn’t find answer.

Thanks :slight_smile:

If you have a nvidia graphic card and you’re using the nv driver, adding the line :

Option “HWCursor” “false”

in the Device section of your /etc/X11/xorg.conf might solve the problem and bring the cursor back.
If that sounds too complicated, install the nvidia driver. It’s much better under Linux anyway.
If you have an ATI card, I don’t know.

I forgot to mention :slight_smile:

I got Intel graphics.

This intel documentation mentions some of the options available for the intel driver. In particular, maybe this option can help

Option “SWCursor” “boolean”
Disable or enable software cursor. Default: software cursor is disable and a hardware cursor is used for configurations where the hardware cursor is available.

If you are using openSUSE 11.2 you may not have xorg.conf file (not usually needed now), however some graphics hardware does work optimally without it. (There are plenty of threads detailing how to create a minimal xorg.conf at runlevel 3 with ‘sax2’ or
‘X -configure’ utilities if required). From there, you can add any options via a text editor as root.

Question aside of this thread: Why exactly did you move? :wink:

I try not to ask “why” when people ask “how”, but I was wondering the same thing.