Cursor becomes tiny in certain applications

I’ve just upgraded from 42.3 on an HP ENVY x360 convertible PC following the SDB:System_upgrade post. All went pretty well with three exceptions. These I mention just as an FYI, as I’ve taken care of them. This PC will not boot (freeze up just after GRUB) when using the default kernel for 15.0 . I know from past experience that the kernel version must be 4.12.4 or higher but not higher than 4.12.9. The second was no DNS resolution. That was fixed using suggested fix at thread post #12.

This issue: When the active window is one of those programs installed by default all appears to be OK, however in Thunderbird, Chrome, Darktable and others the cursor is so tiny as to be nearly invisible.

The Data:

openSUSE 15.0 KDE , touchpad disabled, mouse enabled

~> uname -a
Linux 4.12.4-1.g2a27bf2-default #1 SMP PREEMPT Fri Jul 28 05:45:21 UTC 2017 (2a27bf2) x86_64 x86_64 x86_64 GNU/Linux
# lspci00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 02)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 02)

Applicaton Launcher>Configure Desktop>Hardware>Display and Monitor>Displays>Scale Display is set to Scale=2

no help? comment?

I’m not seeing the same problem. For me, the cursor is the same size on Thunderbird as elsewhere.

But this is different hardware, different install (clean install of 15.0 rather than upgrade) and probably different themes, etc (mostly the defaults).

… and I do not use KDE since Plasma5 came along, so I cannot help.

Are all those apps you listed built with GTK3? If so, you might be missing a GTK3 theme or metatheme that supports QT/KDE’s Scale=2. Just last night I had to select Adwaita to get some 15.0 mouse pointers up to a usable size, but that was in TDE sessions.

Thank you to all three who replied. I confess the display on this laptop is very atypical, and the high resolution is probably throwing something off, but I’m still at a loss to figure out what. I tried numerous different themes prior to posting, including the ones that had worked just fine on 42.2 & 42.3, but no joy.

Yesterday I had to post process a couple of hundred RAW camera files in Darktable. The cursor was less than a mm tall and very hard to see, and I can tell you my eyes got really, really tired by the end of the day.

Then today I opened the computer and the cursor is now normal sized in all those applications. I have done no upgrades or patches or anything at all since yesterday, so I’m at a complete loss to explain the change. I’m just happy it happened.