Current update repository: None

Have done a fresh install of 11.1, and mostly all good, but trying to setup online update, and going in to Yast>Software>Online update config and I am told “Current Update Repository: None”. If I do Advanced and “Register for support and get update Repository” and “Configure Now” it goes off and does stuff, and comes back and says “Software Repositories did not need to be changed”. Going out and back in still gives the same message… So far haven’t had any updates…

Same exact symptoms here, except I did an update from 11.0 factory to 11.1 release. Added three(!) mirrors (in this order of priority):

All repos refresh fine, I even tried to skip the name entry for the main one (it showed up as simply “11.1”), but the update config screen shows nothing for update repos.

When I do “Register for support…” and check only the first two boxes but not “registration code”, it does something and then says repositories did not need to be changed. If I check “registration code”, it opens a browser and says “thanks for purchasing, enter your code”:), but of course I didn’t purchase anything and thought that online update is available regardless of a purchase.

Oh, but the update applet in the KDE4 taskbar now works:) Which I guess is all that really matters, unless someone is running with no graphics and still wants autoupdates.

Run the Yast control panel thing, then under the first tab at the top (Software), open “Software Repositories”.

Toward the bottom in the middle, click on “Add”, then select “Community Repositories” from the list. It should be 2nd from the top.

Now click on “Next” and if you are connected to the Internet, it should download a list of repositories you can choose from.

On a hunch . . . try changing the repo Online Updates repository name to “Main Update Repository”.

Since I have the same problem as the previous postes I tried this but it did’nt solve the problem. I furthermore re-did the “online update configuration” and it gave a sucssfully completed. But when checking there was still stated “none” at current update repository in the online update configuration. Has anyone got an idea what else to try or in which config file I can add the update url manually to make the kupdate applet work again. Thanks in advance for your help

I have to admit to being a bit confused by this myself (as is my nature…)

What I have been doing is hitting YaST -> Software management -> View -> Repositories

Then Package -> All in this lists -> Update if newer version available.

Seems to work… But does leave me wondering what the other bit is actually for?

If only the official updates are wanted, and especially if additional repo’s (like Packman, nvidia, etc.) have been added, it is arguably safer to select the update repo under the Repositories filter and then use the “update all in this list” feature.

Having said that, if the automatic updater applet is not working properly, Yast Online Update is preferable because it describes each patch (as the updater does if “details” are requested).