current state of 8151 AGP tunnel bug

I remember having some issues with my AGP card on my dual Opteron system running Win XP Home and remember reading about an AMD 8151 AGP tunnel bug. Is this fixable by a BIOS upgrade now? What is the deal with this? The mobo in question is a Tyan 2875.

Also, will this even be an issue running, say, a game under wine?


In my case it’s not fixed. I tried to get a GeForce 7600GS working on my S2875, but it was not stable. I used Windows XP with the latest AMD drivers, AGP-, CPU- and NVIDIA 175.16, without success. The system freezes when I run 3DMark03 at least twice.
The system is stable with my GeForce FX5200, but to slow for game play. In other forums I found the same results with the TYAN S2885. I didn’t use the latest BIOS V3.04, because this one fixes only SIL3114 problems.
I think it’s some kind timing problem in the AMD-8151. Sometimes I got blue screens (0x0000009c ), which are generally caused by defective hardware.

This is a wild stab in the dark…
Are both of you trying to run the cards at agp 8x? Have you tried setting it to 4x in the bios?
The reason I ask is my Soyo board is supposed to support 8x but refuses to run any card at that setting so I am forced to run at 4x.

Believe me, I tried everything. Of course switching to AGP 4x too. But the system doesn’t boot then.
Seems like the 7600GS only accepts AGP 8x. This makes sense, because it needs bandwidth.
I’am sure it’s a bug in the AMD-8151. Support for this chipset suspended already 2 years ago.