Current Backend does not support ...

I just tried to install Java 7 via an RPM file and when I clicked on it I got:

“Your current backend does not support installing files.”

What is this??? Never saw it before. This is on version 13.2 updated from version 13.1


In my case, I get this weird error with every rpm I have installed so far (though I could install packages on second run). It’s not a big issue, but I’d be nice if there is a fix for this.

P.S: No intent of hijacking the thread, Just seconding the issue.

Thanks & Regards,

I do not feel that you are hijacking the thread… In fact I am glad to see that there is another complaint. Maybe they will fix it. I searched the forum and it looks like this was a problem in RC1 … that never got fixed. Yes I too found that another try or two will allow the install to continue.


Have you tried downloading the RPM and installing using zypper?

It looks like you are using apper? maybe? It does help trouble shoot if you state which of the many apps you are using to install said RPM. Obviously it is not the RPM program :stuck_out_tongue:

Same here.
Fresh install of 13.2.

I got this error, while installing VirtualBox and Chrome.
Retrying seems to help here.

I get the same in a new Tumbleweed install.

Just a point you do have to be root to install.

It is still not at all clear what program you are using to install the rpm

You should be asked for the root password if necessary.

It is still not at all clear what program you are using to install the rpm

Apper, that’s the default in KDE.
And it does indeed seem to have that problem: It doesn’t work the first time. Try it again, and it installs.
After waiting 15 seconds until packagekitd shuts down, it would fail again (the first time).

I am not sure yet whether this is a problem with Apper or PackageKit, but it definitely is worth a bug report.

Yes, I’m wondering if this is might relate to Gnome desktop utility (eg gnome-packagekit) or similar? It would be useful for those reporting this issue to provide a little ore info about desktop environment being used, and the package management tool in question.

The buttons in the screenshot in the second post definitely look like KDE’s style (Oxygen).
But I think that dialog actually comes from PackageKit.

It would definitely be good to have a clarification from those who reported it though, yes.

Hm, I cannot reproduce that behaviour any more, it works every time now, even if I wait until packagekitd has shut down.
So it seems to fail more random, or maybe only once per session? But it failed more than once here when I wrote that…:\

Well, and as soon as I submitted this post, it failed again…

PS: It’s been filed already 2 weeks ago anyway:

I did think I saw a bug report about this somewhere, but wasn’t sure…

The package that I was trying to install was: jdk-7u71-linux-x64.rpm

I am working on some Android code and needed it installed on 13.2. I was able to install it on 12.3 and 13.1 with no problems.

Just a simple point and click in Dolphin.


Yes. So you are indeed opening it with Apper.
Try it a second time, after you got the error message, and it should work.

I just got an update this morning and then tried right clicking Open With >> Apper Installer and it’s back to how it used to be. But it’s hit and miss and the orignal message can come back, a retry usually works though by the looks of it.

Yes, as the bug report mentions, but of course you don’t need to rely on Apper to fulfill your software management needs. YaST or zypper will do all that you need.

Yeah, I’ve started using zypper for a more comprehensive approach. The right click ‘open with’ option is just cute and lazy when flying along - not that you necessarily get an install at the end of it, RPM’s seem to be the forgotten ******* son half the time, so it seems to me anyway.

As a KDE user, I can right-click on a given RPM file and have it launch ‘package-manager’ (provided by libzypp), which launches YaST.

Thanks, I’ll give that a try.