Curl security update and yast2

I am having trouble with the latest Curl security update (2014-547). It shows up in yast2, but only includes the deletion of curl, libcurl4 and libcurl4-32 and does not show the installation of -.2.27.1. If I let it install, I get an installation of package failed error saying that each of the 0-2.23.1 packages is not installed (which is true). If I check ignore, yast goes ahead and erases libcurl4 (but not libcurl4-32 or curl), which of course hoses Yast. On the version list for each of these packages it shows 3 entries with check marks for 2.27 and one with a check mark for 2.23, as if both were installed. I went ahead and manually upgraded, in Yast, to 2.27 for each of the 3 packages, which seemed to have worked, but this has no effect on the presence of the security update nor the multiple installed check marks in each version list, including 2.23. I did have a power supply fail on me, possibly during an update, so this could have hosed this entry in my package inventory, though it seems to be the only error that I can detect.

Is there a way to fix this? I’ve searched, but can’t seem to find an answer. In the mean time, I’ve marked the security update as Taboo.


Open up a terminal and run;
sudo rpm --rebuilddb
sudo zypper ref
sudo zypper ve
sudo zypper up

The first one will rebuild the RPM package database which may take a few moments, then refresh repos, verify that packages installed are of consistent versions and the try updating.

Thanks, this worked.