CUPS stopped accepting requests

I have SuSe 10.1 with CUPS version 1.1.23.
I installed HP Photosmart C4480 printer a few days ago.
This model is not included in the list of installed drivers, so I tried to install the PPD-file “hp-photosmart_c4400_series-hpijs.ppd”, but I got an error message:
Checking file “./hp-photosmart_c4400_series-hpijs.ppd”
./hp-photosmart_c4400_series-hpijs.ppd: FAIL
FAIL BAD Product - not “(string)”.
REF: Page 62, section 5.3.
FAIL BAD ShortNickName - longer than 31 chars.
REF: Pages 64-65, section 5.3.
WARN Obsolete PPD version 4,0!
REF: Page 42, section 5.2.
WARN PCFileName longer than 8.3 in violation of PPD spec.
REF: Pages 61-62, section 5.3.
0 files passed

I don’t know where to find the pages that are referred to in the message.

So I used the PPD of Photosmart 3300 PPD-file instead, and everything went fine. The printer worked a few days exactly the way it should.
But suddenly something happened, and the printer stopped responding. Yast2 tells, that the connection between the computer and the printer is allright (testing the connection makes the printer to print words “Hello World”), but when Yast2 tries to test the PPD file, a message is given:
“When saving a string y2test there was an error when sending a message to CUPS-server.
cups(File)DoRequest error: client-error-bad-request”

After this unsuccessful test, the system log shows these three lines:
“Dec 18 23:19:08 piika hp: unable to open /var/run/hpiod.port: No such file or directory: prnt/hpijs/hplip_api.c 84
Dec 18 23:19:08 piika hp: unable to connect hpiod socket 50000: Connection refused: prnt/hpijs/hplip_api.c 703
Dec 18 23:19:08 piika hp: unable to send ProbeDevices: Broken pipe”

When trying to print something from the text editor (unsuccessfully), nothing is shown in the system log.

Am I correct assuming the “Broken pipe” is situated between the text editor and CUPS, not between CUPS and the printer?

Where is the script that asks for “prnt/hpijs/hplip_api.c 84” to open. I went through cups-config and cupsd.conf but could find nothing referring to this missing file. In printers.conf I found a line “StateMessage Unable to open USB device ‘usb://HP/Photosmart%20C440%series?serial=TH859D158KO557’:No such device”

Who broke the pipe? Why did it work first and then stopped working? And what could be wrong with the appropriate Photosmart c4400 PPD-file?

From your post, I am not quite sure whether you have checked
which gives you direct access to CUPS.

I have often found that an unexpected stop in printing can be resolved this way.

You also get direct access to CUPS Help.