Ctrl-Alt-F1 almost always gives black screen ( 11.2,, gnome 2.28.2)

On rare occasions, Ctrl-Alt-F1 does work! – recently, from “less” in a Gnome xterm, for example. Successful outcomes are not reproducible, however.

“chvt 1” under root produces the same black screen, so the problem is not due to a bad keymap or undetected keystroke. There is no cursor on the screen. Caps Lock does function, as does Alt-F7: system is not frozen.

I tried killing the X Server (using Ctrl-Alt-Backspace). Ctrl-Alt-F1 then works properly but only till I log in.

I tried changing the boot options:
: eliminated splash and quiet
: changed vga=0x317 to vga=0x314
: eliminated vga altogether
: added console=tty1
: added console=tty2
: added acpi=off

Google reveals that variants of this problem have been around since 2005.

My computer is an Acer Travelmate 2310 laptop

Monitor data from Yast2 hardware report:

51: None 00.0: 10000 Monitor
  [Created at fb.71]
  Unique ID: rdCR.EY_qmtb9YY0
  Hardware Class: monitor
  Model: "Generic Monitor"
  Vendor: "Generic"
  Device: "Monitor"
  Resolution: 1024x768@76Hz
  Driver Info #0:
    Max. Resolution: 1024x768
    Vert. Sync Range: 50-90 Hz
    Hor. Sync Range: 31-61 kHz
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Cannot find xorg.conf /var/log/Xorg.0.log ends with:

(II) Open ACPI successful (/var/run/acpid.socket)
(II) SIS(0): Setting standard mode 0x64
(--) SynPS/2 Synaptics TouchPad: touchpad found
(II) AT Translated Set 2 keyboard: Device reopened after 1 attempts.
(II) Sleep Button: Device reopened after 1 attempts.
(II) Power Button: Device reopened after 1 attempts.
(II) Power Button: Device reopened after 1 attempts.

There are SOME suspect messages in Xorg.0.log:

(--) SIS(0): Hardware supports two video overlays
(--) SIS(0): Detected SiS302LV video bridge (Charter/UMC-1, ID 1; Rev 0xe1)
(--) SIS(0): No CRT1/VGA detected
(--) SIS(0): Detected LCD/plasma panel (1024x768, 1, non-exp., RGB18 [12c500])
(==) SIS(0): Using gamma correction (1.0, 1.0, 1.0)
(II) SIS(0): CRT1 gamma correction is enabled
(II) SIS(0): Separate Xv gamma correction for CRT1 is disabled
(II) SIS(0): CRT2 gamma correction is enabled
(--) SIS(0): Memory bandwidth at 32 bpp is 665.784 MHz
(--) SIS(0): Detected LCD PanelDelayCompensation 0x0c (for LCD=CRT2)
(--) SIS(0): Detected LCD PanelDelayCompensation1 0x00 (for LCD=CRT1)
(--) SIS(0): 302LV/302ELV: Using EMI 0x600d705f (LCD)
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Module "ddc" already built-in
(--) SIS(0): CRT2 DDC probing failed
(==) SIS(0): Min pixel clock is 10 MHz
(--) SIS(0): Max pixel clock is 400 MHz
(II) SIS(0): Replaced entire mode list with built-in modes
(II) SIS(0): Correcting missing CRT2 monitor HSync range
(II) SIS(0): Correcting missing CRT2 monitor VRefresh range
(II) SIS(0): "Unknown reason" in the following list means that the mode
(II) SIS(0): is not supported on the chipset/bridge/current output device.
(II) SIS(0): <default monitor>: Using hsync range of 30.00-80.00 kHz
(II) SIS(0): <default monitor>: Using vrefresh range of 59.00-61.00 Hz
(II) SIS(0): <default monitor>: Using vrefresh value of 71.00 Hz
(WW) SIS(0): Unable to estimate virtual size
(II) SIS(0): Clock range:  10.00 to 400.00 MH

CRT2 does not exist: I have only the laptop screen.

Interesting problem? Why does the console switch work SOMETIMES (at random intervals)?

Are you using Nvidia drivers?

No bsilvereagle. There is no mention of Nvidia anywhere in the hardware report, the dmesg output or the Xorg log. The driver seems to be unidentified (or “generic”). Here is the relevant dmesg output:

    1.028721] pci 0000:01:00.0: Boot video device
    1.028958] pci-stub: invalid id string ""
    1.029125] vesafb: framebuffer at 0xe8000000, mapped to 0xdc680000, using 3072k, total 16384k
    1.029139] vesafb: mode is 1024x768x16, linelength=2048, pages=4
    1.029149] vesafb: protected mode interface info at cbe7:0004
    1.029158] vesafb: pmi: set display start = c00cbe9e, set palette = c00cbee2
    1.029169] vesafb: scrolling: redraw
    1.029177] vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0
    1.029527] bootsplash 3.1.6-2004/03/31: looking for picture...
    1.049035] bootsplash: silentjpeg size 100573 bytes
    1.049065] bootsplash: ...found (1024x768, 27393 bytes, v3).
    1.144858] Console: switching to colour frame buffer device 124x44
    1.240900] fb0: VESA VGA frame buffer device

hwinfo --gfxcard


hwinfo --gfxcard
21: PCI(AGP) 100.0: 0300 VGA compatible controller (VGA)        
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_1039_6330
  Unique ID: VCu0.IPKspuIsWy7
  Parent ID: vSkL.uvrveDpO5n6
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "Silicon Integrated SiS 660"
  Vendor: pci 0x1039 "Silicon Integrated Systems Corp."
  Device: pci 0x6330 "SiS 660"
  SubVendor: pci 0x1025 "Acer Incorporated [ALI]"
  SubDevice: pci 0x0082 
  Memory Range: 0xe8000000-0xefffffff (rw,prefetchable)
  Memory Range: 0xe2100000-0xe211ffff (rw,non-prefetchable)
  I/O Ports: 0x9000-0x9fff (rw)
  IRQ: 7 (no events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00001039d00006330sv00001025sd00000082bc03sc00i00"
  Driver Info #0:
    XFree86 v4 Server Module: sis
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #9 (PCI bridge)

Primary display adapter: #21

One more piece of information:

Sometimes (again infrequently), I get a black screen when resuming after a suspend. When that happens, Ctrl-Alt-F1 works, and from there I can press Alt-F7 to get back into the X window.

Summarizing: Ctrl-Alt-F1 produces a black screen 95% of the time, but when I already have a black screen, Ctrl-Alt-F1 WORKS!

What could explain the randomness? Timing? A synchronization failure?

I’ve read the helpful Xorg tutorial created by OldCPU. Would it be wise to try to create my own Xorg.conf file (using sax2) and switch from vesa to fbdev, say?

The resolution of the Terminals are basically controlled with the vga= option i the vernal line try another resolution. It may be that your monitor may not like the default resolution.

I did try changing and even eliminating vga=, and I tried all of the other boot options I could think of – see my original post. Nothing helped.

Thanks for your interest!

This is a very long shot:

Your laptop has a socket on the back for an external monitor, I think. Could that be the phantom CRT2 in your output?

My theory is, when you press Ctrl-Alt-F1, the hardware forgets whether it should use the internal monitor or try the external monitor. If you press the Fn (in a black square) and F5 keys, which toggles between internal and external monitors, do you regain the console?

Another thing it might have done is turn off the back lighting to save power. If you press any key (other than Alt F7) does that bring the console back?

Hope that helps.

Good suggestions, Plodder! You seem to know my machine!

I have tried Fn F5, however, along with all of the other Fn combinations, and I just tried them again. Unfortunately, I’m still getting black.

But this is interesting: When I press Alt-Right or Alt-Left about five or six times, I end up back in X-world. The Alt-Left and Alt-Right combinations cycle through the virtual consoles. Since I end up in a console, I must be starting out in one. This shows me that Ctrl-Alt-F1 is at least taking me to the right destination. The only problem is that the destination is black, 95% of the time.

Your comment about backlighting is also interesting. Suspend/resume processing on this machine is very strange. The hard-drive starts out hyperactive, coming on and off every second or so. This behavior continues from boot to my first suspend. After I suspend and resume, hard-drive activity subsides to normal. So now I suspend as soon as the boot completes, then immediately resume.

So maybe the backlight is getting switched off by the power-saving software. But your suggestion – pressing a key – does not turn it on.

One more odd symptom: I am not getting fsck progress bars. I believe that the bars are suppressed for “serial consoles” – consoles attached to the serial port. Does my system think that tty1 is a serial console?

Since variants of this black screen problem have been around since 2005, at least, I’m surprised that no one has found a solution. There should be some way to go into the code and generate trace data and error messages. I wonder why no one has ever tried that! :wink:

I think we need to pin down whether the console(s) is (are) completely dead or the screen is just not powered on. By the way are all consoles F1 - F6 missing or just F1?

A couple of things you could try:

  1. All parts of the system (hardware, firmware and software) may not be singing from the same hymn sheet. Press Fn - F6 to force it into power off mode (whatever state it thinks it’s in) and then try pressing a key to wake it up again.

  2. Carefully try logging on to the console even though you cannot see the response to the keys you are pressing. Then execute a command that produces a result that can be inspected from X. For example, create a directory in your home directory (default) by doing

md doesthiswork

Then do Alt - F7 to return to X and see if the ‘doesthiswork’ directory was created. If so, you have an active console although you cannot see what happens on it. May make the problem resolution easier to track down.

You say that there are a number of examples of this problem on Google, dating back to 2005. Can you just quote the search string you used? I did try briefly looking but did not get any meaningful results.

On 2011-02-12 06:36, NonZ wrote:

> Since variants of this black screen problem have been around since
> 2005, at least, I’m surprised that no one has found a solution.

Has anyone created a bugzilla?

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Tried all of the following:

: Fn F6: Toggles backlight (works both in VT1 and VT7 (X))

: Fn F5: Switches between CRT 1, CRT 2 and CRT 1&2 when CRT 2 exists (no effect)

: Fn F4: Puts system to sleep
: : Works in VT7 (X)
: : Moreover,
: : : System sometimes (5%) falls asleep in VT7 and awakes with black screen; Ctrl-Alt-F1 then works!
: : : Ctrl-Alt-F1 often works when first pressed after system awakens

Yes, this works. And when I do manage to get a visible VT1, I see a long line of “^@” symbols after the login prompt, indicating that the keystroke combinations I’ve tried have been detected.

Try “Linux Ctrl-Alt-F1 black”. The first entry Google returns includes a link to a report from 28 Jan 2005. There are also reports from 2007, 2008, … 2011. I’ve followed about 20 of these links. Many leave the problem unsolved; some solve it by changing the boot options, something I’ve already tried.

Thanks again for your interest.

I had a look at a few of the entries for that Google search string but got the impression that there are a variety of causes. For example: bad (Nvidia) graphics drivers in one case and one of the distributions (Fedora or Ubuntu) deciding to change the X console from tty7 to tty1 (I think) in another. It may not be worth pursuing that sort of investigation unless you can track down an example directly related to your setup e.g. hardware distribution and version.

However, just to clarify one point in your answers above, when you say “Fn F6: Toggles backlight (works both in VT1 and VT7 (X))” do you mean that is a viable work around (Y/N)?

I remembered over the weekend that I do have one combination of hardware here that does exhibit the sort of problem you are experiencing. I have a Suse 11.3 x64 system that was installed using a 1280x1024 monitor. This resulted in an automatically generated, Vesa framebuffer mode, grub option of vga=0x31a. However, I then changed the monitor to one of 1280x768. This then produces some strange effects (please check these against your experiences):

  1. After POST, the Grub menu is displayed normally with vga=0x31a shown as an option,
  2. When booting, there is no progress screen at all - the monitor goes black,
  3. When booting has finished, the logon screen is displayed as per normal,
  4. Pressing Ctrl-Alt-F1 produces a black screen (no virtual console) and this is true for F2 - F6,
  5. Pressing Alt-F7 returns me to the X display,
  6. After Pressing Ctrl-Alt-F1, I can press Alt-Right repeatedly (5 or 6 times) and get back to the X display.
  7. When shutting down, there is no shutdown progress bar.

If I change the Vesa framebuffer mode to something the monitor can handle: 0x317, which is 1024x768 (so the frame height must be less than or equal to the screen height and the same applying to the width), everything works as it should.

You might check what Vesa framebuffer mode has been set for your installation. I think in some cases it can be vga=normal (what does that mean???).

Hope that helps.

But I see from your first post you have already tried varying the vga= option.

Sorry I don’t think I can give any more help here.

Good luck.

I’m going to use sax2 to generate an xorg.conf file. With 11.2, the X Server attempts to generate the configuration automatically, so there is no xorg.conf file, by default. However. the opensuse tutorial below states that the automatic configuration doesn’t always work, in which case sax2 (under 11.2) can be used to create the configuration manually. See

OpenSuSE video guide

OpenSuSE video guide (superceded)

If this works for me, perhaps it will work for you too, in which case you will be able to keep your higher resolution.

Problem solved!

Procedure (based on recommendations in the OpenSuSE graphical card guide):

  • Boot the system
  • Use “3” as the boot option, to stop at run level 3.
  • Log in as “root”
  • Run sax2 to create an xorg.conf file in /etc/X11:

sax2 -p
sax2 -m 0=vesa 

  • Rebooted
  • Logged in to xfce
  • Tried Ctrl-Alt-F1 repeatedly, and entered virtual console 1 every time!


If 0=vesa had not worked, would have tried 0=fbdev. The “0” is the chip number that displayed when I entered sax2 -p

# sax2 -p
Chip: 0  is -> SiS SiS 660                      01:00:0 0x1039 0x6330 AGP sis

Now I think I will switch to gnome and try Ctrl-Alt-F1 from there. The desktop shouldn’t matter, since the problem was apparently caused by the X Server configuration.

You never did identify the graphics driver that was in use when you had the problem. That could have been determined by looking at the complete /var/log/Xorg.0.log file. From what I can see, its possible you were using fbdev graphics all along and running ‘sax2 -m 0=fbdev’ might have kept the original problem.

Surfing suggests the Acer Travel Mate 2310 has SiSM661MX graphics. This is confirmed by some information you posted:

  Model: "Silicon Integrated SiS 660"
  Vendor: pci 0x1039 "Silicon Integrated Systems Corp."
  Device: pci 0x6330 "SiS 660"
  SubVendor: pci 0x1025 "Acer Incorporated [ALI]"

The proper graphics driver for that hardware is, I think ‘sis’. If you type ‘man sis’ you will read what graphics the ‘sis’ driver supports.

You could try backing up your /etc/X11/xorg.conf files, and then try:

sax2 -r -m 0=sis

and if that does not work, simply restore the backed up xorg.conf file.

Almost for certain, the ‘sis’ driver will provide superior performance over the ‘vesa’ driver.