Ctl-f11 shortcut no longer works

just updated,
systemsettings5|5.27.10-1.2|x86_64 – prior
systemsettings6|6.0.3-1.1|x86_64 – current

systemsettings still shows i have these shortcuts:
ctl-f9: toggle overview
ctl-f10: toggle present windows (all desktops)
ctl-f11: show desktop grid
ctl-f12: minimize all
alt-f12: peek at desktop
f11: fullscreen
f12: minimize

all but ctl-f11 still work.

with focus on an xterm, when i hit ctl-f11:
on an un-updated tumbleweed, “show desktop grid” works and the xterm shows nothing.
on an updated tumbleweed, “show desktop grid” doesn’t happen and the xterm shows: 5~

that’s probably an important clue. anyone know where to go with it?

On kde plasma ctrl+alt+t will open a konsole instance, but performing the shortcut again will open a new terminal instead of focusing the one open …

To open XTerm with a shortcut go to systemsettings->Keyboard->shortcuts and click on Add New->Application... then select XTerm in the list, that way you will be able to to set a shortcut to open the application, but like konsole the shortcut will open a new terminal every time …

But you can still set another shortcut to focus Xterm ( or any app really ), open XTerm, right click on the app icon on the top left, more actions ... and Configure Special Application Settings ... here by clicking Add Property...Shortcut you will have an option to set a shortcut to focus this application window, but you cannot use the same shortcut as the one that open the application unfortunately…

It is still possible to set a shortcut that do both, open the app and focus the app if it’s already open, to do that you can from System Settings->Keyboard->Shortcuts->Add New->Command or Script to link a command or a script and bind with shortcut for it,
for example I’ve managed to achieve this result with this poorly written bash command I’ve made…

wmctrl -a  $(wmctrl -l -x | awk '{print $3 $1}' | awk '/^my-xterm.XTerm0x[0-9]+e$/{print $0}' | awk 'match($0,/0x[0-9]+e$/){print substr($0,RSTART,RLENGTH)}') -i || xterm -name "my-xterm"

One other solution is to use another terminal like Yakuake Yakuake - KDE Applications it’s a terminal that is always open, hidden and shows up when pressing the shortcut to display it, from my personal experience it work well even if plasma crash the terminal stay open so …

And for last … by pressing ctrl+alt+F1-12 you can switch from one virtual terminal to another, advantage of it is that if you perform a command like a system update without worrying about your graphical session crashing, your virtual terminal will stay up and running SDB:Upgrade Tumbleweed - openSUSE Wiki

In Plasma 6 per default
“show desktop grid” is Meta+F8
“toggle grid view” is Meta+G
“peek at desktop” is Meta+D

So either you have old/incompatible/overlapping settings from your old Plasma 5 configuration or your profile is borked.

For what it worth, on my side ctrl+F11 was not bind to anything in system settings and the shortcut do nothing, I can’t speak of how it worked on plasma 5 since I’ve never paid attention to it …

On my side :

  • “show desktop grid” is set to Ctrl+F8 ( default )
  • “toggle grid view” is set to Meta+G ( default )
  • “peek at desktop” is set to Meta+D ( default )

Meta+F8 is not set to anything on my side.

Systemsettings shows me that my settings, a mixture of default and custom settings, were preserved as i set them. That’s good, that’s not the issue. The issue is that “show desktop grid” isn’t working. When i press either ctl-f11 (my setting) or ctl-f8, “show desktop grid” doesn’t happen, and if focus was on an xterm, i see 5~

My question is why isn’t “show desktop grid” working for me? is it a bug in plasma6? is it something about my settings? is it something about keyboard bindings? Why does it put 5~ in my xterm instead?

My apologies I’ve completely misunderstood your problem …

So show desktop grid ( or ctrl+f8 ) on my side does nothing, I’ve tried to click on the default button, un-check and check again the shortcut … but no, it doesn’t work.

After a quick search on the internet it seems that the shortcut is now called Toggle Grid View and have Meta+G as default shortcut, this one work on my side.

So is “Show desktop grid” merely malfunctioning or has it been intentionally discontinued? it still exists in systemsettings>input&output>keyboard>shortcuts>kwin. And tho similar to “Present windows” et al, “Show desktop grid” is best at rendering the windows the largest and easiest to recognize (due no doubt to lack of other clutter)(and it leaves the screen backgrounds intact) and has thus been my preference for finding and selecting windows.

And i gather that i’m not allowed to adjust the title of this thread? So if i want a different title i just need to start a new topic?

From what I’ve read it is still listed in your settings if you upgrade from plasma 5 to plasma 6 but the settings does nothing and is no longer listed if you create a new user for example.

Also if that can help, from the discussion linked before

I miss Desktop Grid also. Apparently they combined Desktop Grid and Overview effects into one. I don’t like that…
After you activate Overview, you can activate Desktop Grid with Meta+G.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.