crypt partitions

OK, I’m being a dumb girl here - I tried to create a crypt partition in YaST and all goes well but for some reason it tries to create loop0, which already exists as I have another encrypted drive. Shouldn’t YaST automatically select, say, loop1 for this task?

I created some dummy file in a directory, gave YaST that path name as the “loop file,” checked “create loop file,” and format, encrypt, and mount and all goes well until the mount, and it tries to mount to loop0 - but can’t, and so fails.


Please somebody point me to a page that gives the simple command line syntax for unmounting and mounting crytp files (used as partitions) - I am trying to create secure volumes. I was able to create them, but don’t know 11.1’s syntax for doing this.

Will this help?

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 1:04, 2 users, load average: 1.23, 0.44, 0.16
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

Thank you, Malcom - it’s slowly starting to come back to me - part of the command was “losetup,” I believe. The trouble with that page is it jumps around between openSuSE versions, and I remember the whole crypt thing changed. On this page I found a tutorial - but since I just used YaST/System/Partitioner to create a crypt file, I’m not really sure where I’m at. I can easily unmount the partition from the command-line, but I’m not sure how to get it mounted again, because I’m not exactly sure what YaST did. I only found one reference to using YaST to make crypt files, and it wasn’t very detailed. I just tried it on my new laptop. First I did
#> touch junk
…to make the target file for YaST.

All went well and this is what crypttab now says:
**cr_junk /home/patti/junk none none
and this is what fstab says:
**/dev/mapper/cr_junk /crypt1 ext3 acl,user_xattr,noauto 0 0
It’s currently mounted, but I don’t no how to remount it from the command line the next time I need it. I don’t want to mount it at boot time even though it gives me the opportunity at boot. I know I can remove that line from fstab to prevent boot-time asking to mount…

Wow… 'been days and days of searching and I just can’t get an answer. I created crypt files for use as crypt partitions, but can’t find the way to let my users mount them and unmount them at-will. The only way to mount them seems to be at boot time!

Is there a wizard in the house??? :’(

Please, can someone help me!?! I’ve wasted days of digging through jargon of encrypted root and home partitions - I have crypt files with formatted filesystems in them with the right privileges, but I need my users (not root) to be able to mount and unmount them. (and not asking for passwords at boot-time) Can someone help me find the (users) command line syntax?

Please help!!!

/dev/mapper/cr_00Patti.001 /home/patti/MyShares/flames ext3 acl,user_xattr,noauto 0 0
/dev/mapper/cr_00Paul.001 /home/paul/MyShares/flames ext3 acl,user_xattr,noauto 0 0
cr_00Patti.001 /SCRATCH-RAID10/Dirs/00Patti.001 none none
cr_00Paul.001 /SCRATCH-RAID10/Dirs/00Paul.001 none none