cryfs: Wrong version installed. The required version is 0.9.6

Hi

I’m using OpenSuse Tumbleweed with KDE. I installed KDE vault which is available as part of the new update. When I try to select the cryfs it is give me error message “cryfs: Wrong version installed. The required version is 0.9.6 fusermount: Correct version found” . But i don’t have any issue while selecting encfs type.

Please let me know what might be the issue in this.

I’m using

KDE Plasma version 5.12
KDE Framework version 5.42
openSUSE Tumbleweed 20180213-0

Vipin

As a starting point,
You’ll have to post information about your cryfs, where you got it from and its version.
A search at https://software.opensuse.com/search returns the fact that various versions of cryfx for TW has been built, but they’re all private repos.
I see that the latest version available (cryfs 0.9.9) is available in a malcolm lewis repo (likely recommended over others).

https://software.opensuse.org/package/cryfs?search_term=cryfs

It also looks like building from source can be easy.
The instructions to build from source are available at the following page, and based on a superficial inspection the package list for Fedora look like the package names for dependencies you would use for openSUSE, just use “zypper” in place of dnf. Building from source will have the downside of no automatic package management including auto updates, but would ensure latest code from the Project. Instructions on the page describe how to create your own RPM if you wish for integration with your Package Management.

https://github.com/cryfs/cryfs

So,
I’m doing a bit of personal speculation that there is an error in the code that specifies and checks the exact version of fuse compiled into your version of cryfs instead of specifying only a minimal version. That would mean that on a system like TW that rushes updates and changes to the User, cryfs will break often. Short of fixing the code, this may mean that once you are able to get a working cryfs, you’ll want to lock the fuse package on your system.

In any case, you should submit a bug report…
Although you might do so to https://bugzilla.opensuse.org, I suspect this likely affects all development distros and not jut TW so recommend you should instead submit to the github Project instead if you are able to do so (would require a Github account but that’s a very good thing for you to have if you don’t already have one).

HTH,
TSU

Hi
From the spec file;


# plasma-vault supports cryfs and encfs, but we only have encfs here (for now)
Requires:       encfs

Ref: https://build.opensuse.org/package/view_file/openSUSE:Factory/plasma-vault/plasma-vault.spec?expand=1

Needs to be built with cryfs support. There are plans underway by another user to push cryfs to Factory/Tumbleweed. Once that happens, I’m guessing cryfs support can be added…

[QUOTE=malcolmlewis;2856008]Hi
From the spec file;

plasma-vault supports cryfs and encfs, but we only have encfs here (for now)

Requires: encfs

Ref: File plasma-vault.spec of Package plasma-vault - openSUSE Build Service

Needs to be built with cryfs support. There are plans underway by another user to push cryfs to Factory/Tumbleweed. Once that happens, I’m guessing cryfs support can be added…

Unclear to me,
Are you suggesting that existing packages won’t work with KDE/Plasma but would work with another Desktop?

And, if this is the issue then it seems to me that doing your own build should address the problem.

TSU

[quote="“tsu2,post:4,topic:130353”]

Hi
I imagine so, but unsupported, that’s up to the Plasma folks to enable if and when it’s ready…

[quote="“malcolmlewis,post:5,topic:130353”]

Apparently, Plasma issues with cryfs aren’t being reported in cryfs, but here are a couple recent Plasma/KDE comments

TSU

Hi

Please find the steps to reproduce my issue. I have attached a word document in this link. This is explaining the complete issue with screenshot.

http://goo.gl/W3HtkE

Thank you,

Vipin

I’m pretty sure that the people working on this have as much info as you posted but if you think you are able to contribute something significant, you should probably open or append to a bug in the kde bugzilla.

TSU

As has been pointed out already, cryfs is not supported in Tumbleweed currently (actually it is not included at all).
A bug report won’t help with this either.

Upstream KDE even changed the default to encfs in plasma-vault 5.12, because “CryFS is still not considered stable, and it has issues when using
it from an automated UI”…
https://cgit.kde.org/plasma-vault.git/commit/?id=a07e32648224d6ddf29daadc2fbf00ab6f3e764c

PS:

AFAICS, there is no special need to build plasma-vault with cryfs support.
It should find it on runtime if installed (in a suitable version).

It hasn’t been patched out in the openSUSE package or something… :wink:

PPS: I somehow have the feeling that one thing is still not clear here (judging from the provided “word document” and some of the previous comments).

In order to use plasma-vault with cryfs, you need to install cryfs manually from some 3rd party repo. It’s not included (yet) in Tumbleweed, and therefore cannot be installed automatically anyway.
And you need at least cryfs 0.9.6.

encfs should work out of the box though.

Hi
All correct, there is a user looking at pushing it to Tumbleweed, maybe 0.9.9 is a bit better…

in my laptop with OS=leap 42.3, DE=plasma 5.12.1, KDE frameworks 5.43.0, KDE applications 17.12.2, Kernel 4.4.114-42-default, nvidia drivers
this error appear
encfs: Correct version found
encfsctl: Correct version found
fusermount: Wrong version installed. The required version is 2.9.7

Isn’t it obvious?

plasma-vault requires fusermount in version 2.9.7 or higher.
Hint: fusermount is part of the package “fuse”, now check which version is installed.

The one in Leap 42.3 is just too old…

Maybe it would work to install a newer fuse from somewhere, but I haven’t tried. (there may be conflicts)

…not so obvious lol!

…I didn’t catch that fusermount was part of something, found in /repositories/filesystem and installed, it seems to works fine manythanks lol!

If you’re using fusermount manually because Vault won’t without a newer version,

You might find some useful information in the SDB VMware Tools, which describes some basic commands and concepts (The VMware fusermount tools are re-named fuse tools)

https://en.opensuse.org/SDB:VMware_Tools

TSU

On Fri 23 Feb 2018 04:06:01 PM CST, wolfi323 wrote:

PS:
malcolmlewis;2856008 Wrote:
> Needs to be built with cryfs support.

AFAICS, there is no special need to build plasma-vault with cryfs
support.
It should find it on runtime if installed (in a suitable version).

It hasn’t been patched out in the openSUSE package or something… :wink:

Hi
And it’s now in Tumbleweed…


Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.3|GNOME 3.20.2|4.4.114-42-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Yes.
You still need to install it (manually) if you want to use it though. :wink:

But there’s no need for extra repos anymore.