cryfs out of date

“Failed to open: The installed version of cryfs is too old to open this vault.”

Why is the cryfs version so old. says 9.9 has been in use since at least 15.0, and even the beta 15.4 still shows version cryfs 9.9 while Tumbleweed uses 11.2.

An upgrade to 10.anything would solve the incompatibility. How do we get a backport or security upgrade?


Has 0.10.2 for 15.x, would have 0.11 but it fails due to cmake issue.

You probably mean

Thanks, I downloaded the cryfs 10.x binary, which solved the problem. Now, what’s the process for getting that where end-users like me will find it? Preferable in the repo’s, or at least ?

You cannot have it in the latter without having in the former. software.o.o is just a search engine for repositories.

Building of new version fails on Leap 15.3 because it needs range-v3 which is missing. So you would need to either patch out this requirement for Leap 15.3 (assuming it is optional) or provide it for Leap 15.3 so that cryfs can use it.

Bear with me, I’m just an end-user [scratching head in confusion]; since 99.99% of users are not going to “build” this, they’re just installing it…why are we shipping an outdated version that won’t open a file from any other distro? Even Debian Stable, which is notorious for being outdated, is shipping 10.2-5

Thanks for the education,

It shows up under the “Show Experimental Packages”.

Unfortunately the s.o.o for 15.3 is broken and has been since it came out. I won’t say anything about it because it wouldn’t be pretty and I’d get banned from here if I said what I think about the main search engine for the distro being broken for 9 months.

Perhaps it’ll be fixed for 15.4.

Yes, Bullseye also ships range-v3. Somebody needs to submit it to Leap 15.3. It does not happen by itself.

S.O.O. is being decommissioned…