Crontab Segmentation Fault

I’m not sure what happened after installing a new crontab, but now when I run crontab -l or crontab -e, for any user, I get “Segmentation fault (core dumped)”.

I’ve tried forcing a re-install via zypper, but no good. Looking at the crontabs in /var/spool/cron/tabs, they look okay with no strange characters and such. I’ve even tried deleting a tab to see if it would recognize that there is no tab installed, still no good. Any ideas on what look over next?

I do not think that the crontabs themselves are wrong.

It is the crontab program (/usr/bin/crontab) that breaks. Not allowed to happen of course no matter what data it tries to swallow.

So you should concentrate on the version and eventual updates of crontab, not on the contents of the crontabs.

Okay, good plan. I’m running cron-4.2-58.25.x86_64… If I try to delete the /usr/bin/crontab file, and then re-install… that may work? Doing a forced uninstall via zypper mentions it will break 1178 programs. But I don’t see it working right now anyways.

Well… that didn’t work. Zypper reinstall never replaced /usr/bin/crontab. :expressionless:

Ahhh… fixed it. There’s “cron” and “cronie” installed. “cronie” replaced /usr/bin/crontab and now it runs again. Messed up, still not sure how it got that way.

Thanks for the help!