cricket a605 boradband modem

I’m about to try getting a new cricket A605 broadband modem configured on my suse 11.4 laptop. The laptop is a Gateway M-Series.
Right now the only thing I can find is this thread: cricket-a600-usb-broadband-modem-install. It’s a little out dated, so… anyone know of any updated ways of doing this?

TTFN
John

update to that. got to looking through yast and found that I already have usb_modeswitch and the data files installed. Ahh! I feel like such a newbie here, but wireless is not a strong point of mine. What do I need to do to flip-flop this modem to work?

have a read at this

[ubuntu] HOWTO: Cricket Wireless A600 Broadband Modem - Ubuntu Forums](http://ubuntuforums.org/showthread.php?t=1146110)

the Cricket thread just runs and runs on the Ubuntu forum; many seem to struggle

**copy and paste the command **

dmesg | grep tty

into a terminal; ask if you don’t know how …

and copy and paste the results back here; we can try to see if your modem has already been “flipped” so it is seen as a modem …

and from a very recent post from usb_modeswitch data;

http://www.draisberghof.de/usb_modeswitch/device_reference.txt

it would seem the A605 is a ZTE device

ZTE “ffe” devices 1 (e.g. Cricket A605)

Contributor: Matt Eaton

DefaultVendor= 0x19d2
DefaultProduct=0xffe6

TargetVendor= 0x19d2
TargetProduct= 0xffe5

MessageContent=“5553424330f4cf8124000000800108df200000000000000000000000000000”

whereas previous advice said the device needed to be loaded on a windows computer before use, if they are now using a ZTE device, one could only hope it can be configured on linux ab initio

so if anyone inserts such a device into OpenSuse and types in a terminal

lsusb

one should get

19d2: ffe6
when the device is first inserted; as seen as a virtual CD-Rom device;

and after flipping (by selecting eject or using usb_modeswitch)

it should say

19d2: ffe5


so ogbi-web_kenobi

if you can type in a terminal

lsusb

and copy and paste back the answer; that would tell us what you are dealing with

(it seems the version of usb_modeswitch copes with the A605 Cricket is the version —usb_modeswitch-1.1.8— so not sure if opensuse has produced a package for this yet

kenobi@ogbi-web:~> dmesg | grep tty
0.000000] console [tty0] enabled
kenobi@ogbi-web:~> lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 04f2:b027 Chicony Electronics Co., Ltd Gateway USB 2.0 Webcam
Bus 002 Device 003: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 005 Device 002: ID 046d:c51b Logitech, Inc. V220 Cordless Optical Mouse for Notebooks
Bus 006 Device 002: ID 19d2:ffe6 ONDA Communication S.p.A.
kenobi@ogbi-web:~> su
Password:
ogbi-web:/home/kenobi # usb_modeswitch -p 19d2 -v ffe6

Looking for default devices …
No devices in default mode found. Nothing to do. Bye.

ogbi-web:/home/kenobi # exit
exit
kenobi@ogbi-web:~> lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 04f2:b027 Chicony Electronics Co., Ltd Gateway USB 2.0 Webcam
Bus 002 Device 003: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 005 Device 002: ID 046d:c51b Logitech, Inc. V220 Cordless Optical Mouse for Notebooks
Bus 006 Device 002: ID 19d2:ffe6 ONDA Communication S.p.A.

Doesn’t seem to be getting flipped

This might be the problem. I’m see if there is a way to get an update.
kenobi@ogbi-web:~> su
Password:
ogbi-web:/home/kenobi # usb_modeswitch -e

  • usb_modeswitch: handle USB devices with multiple modes
  • Version 1.1.6 (C) Josua Dietze 2010
  • Based on libusb0 (0.1.12 and above)

! PLEASE REPORT NEW CONFIGURATIONS !

I’ll read trough that second link, the ubuntu I’ve already read. No help to me though.

Thanks for advice. This thing has got work some how.

Bus 006 Device 002: ID 19d2:ffe6 ONDA Communication S.p.A.

so the Cricket A605 is a ZTE device

you need usb_modeswitch 1.1.9

doesn’t seem to me there is an OpenSuse rpm for this yet

if you go here

Draisberghof - Software - USB_ModeSwitch

and download TWO things: the data package AND the .tar.bz2

under that paragraph is how to install

Josh says install modeswitch first and then data package

you need to be clear where you are downloading them to: eg I use a directory called Downloads

so in the terminal you need to change directory to that; ie cd Downloads and then hit ENTER and you should be INSIDE the Downloads directory; then you can unpack the modeswitch

the command to uppack is

tar -jxvf filename.tar.bz2

when you have done that

type

ls

when you have unpacked .tar.bz2 you create a directory called usb_modeswitch 1.1.9 (or somesuch) inside Downloads

you need to get INSIDE that

so type

cd usb_modeswitch…
if you start to type usb_m and then hit the TAB key, the terminal should complete the correct entry for you

once inside the directory you type

su -

and get asked for root password; Enter that

then type

make install
… the writing should now be in red, with a HASH sign before it all …

Josh summarises this all by saying

Unpack the source file of the program (who might have thought!). In the newly created directory run as root or superuser:

make install

This installs a small shell script for udev, the larger wrapper script, a config file, the man page and the freshly compiled binary.
Now do the same for the data package. It will install the config files in “/usr/share/usb_modeswitch” ("/etc/usb_modeswitch.d" in earlier versions) and the udev rule file in /lib/udev/rules.d.
You are set already; if your device is known, you should be able to just plug it and use it. If it doesn’t work right away we’ll find out why.

ok, still fighting with this one but getting a little further along each time. I have the modem activated, I have a phone number to the modem
and it is getting flipped. How do I set this up in knetworkmanger and or yast?

The modem is showing up in my system tray icon, but not activating. I tried manage connections, entered my number, username… stop on password. (I not sure if I mentioned this earlier, but I don’t have a windows OS on hand.) After going to mycricket.com and trying to log in, I opted for lost password and it texted it to the modem. What file is the modem ‘stored’ in so I can read this txt as I think that might be my final problem, no password.

Other than that, I lost as to what to do.

I use gnome;
I right-click on Netork Manager (NM) icon (bottom-right)
I left-click Edit Connections
I click on Mobile Broadband Connections
I click Add; then define country; network; (there may be options within a provider: eg prepaid; plan etc
I click to accept;
then I LEFT-CLICK on NM
what you set up should be there
left-click to connect

(I am using a 3G stick now whilst on trip)

I can only hope this works for you