Creative X-Fi - howto install drivers on opensuse 11

hi folks,

i have just reinstalled suse after many years.
and i have to say that it looks really good.

i have installed on a desktop that has vista x64, everything works fine besides the sound.
uname -a
Linux aHost #1 SMP 2009-03-31 14:50:44 +0200 x86_64 x86_64 x86_64 GNU/Linux

it is a Creative X-Fi (PCI-e) which is working fine under vista x64.

i have tried to follow instruction that i have found at creative website:
Creative Linux Sound Card Support

downloaded: XFiDrv_Linux_US-1.18.tar.gz

and extracted the contents and tried the following command in the folder:

which fails with the message.
Setup is unable to detect a supported product on your system
Setup will now exit

i have installed all the necessary packages required for compiling as described in the wiki

i have also found this post on the mailing list that claims that X-Fi is supported on the latest ALSA release.
[Alsa-user] Sound Card SB X-Fi Extreme Audio finally working](

so i tried updating alsa as described in this wiki
Alsa-update - openSUSE

now my card is recognised as a HD-Audio Generic BUT yast does not list it.

i have also run alsa-info tool and its output is here:

i would really appreciate your suggestions on how to install the correct driver for this card.

Many thanks,


Wait until the 2.6.31 comes out that will have X-Fi support in the kernel :wink:

<microchip_> X-FI drivers finally to be added to the 2.6.31 kernel [Phoronix] Finally, A Creative X-Fi Driver Going Into ALSA](

Have a look in this thread. It worked for my X-Fi Xtreme Games PCI. The only problem I have with the drivers is that hibernation/suspend causes my sound to go. Can’t figure out how to create a custom hook to get it working. But it’s something I can live with. It beats swapping around leads when I want sound in Windows… :slight_smile:

@Chrysantine: That’s great news. I am happy to hear that. I must say the latest xfi drivers are small and do work. I remember your reservations when the drivers came out originally. :slight_smile:

Webpin - Results for “Xfi”

it is great to hear that X-Fi will be supported in the Kernel - thanks…

Chrysantine >>
it is great to hear that X-Fi will be supported in the Kernel
so this new kernel will appear on SuSE repo at some point in the ‘near’ future. any idea of time scales?


Dexter1979 >>
your post talks about XFiDrv_Linux_Public_US_1.00 which has been taken over by a later version - have you tried the newer version?


Akoelh >>
i have checked this repo and installed one of the packages (really nice process of ‘one-click-install’), i will reboot now… and post back.

You are mislead by the naming scheme, the 1.18 is a BETA and the “Public-1.00” is newer (yeah, somebody at Creative seems to love smoking strange plants).

I think the last 2 versions that came out were all called 1.18. My latest 1.18 was only like 64k in size, compiled fine after reading the before mentioned thread and is fully working!

hi folks,

apologies for the time it has taken me to reply,

i had to rebuild this machine to accommodate Vista 64 (what headache).

and i reinstalled opensuse

  • installed nvidia display
  • installed compiling software
  • download and installed x-fi driver

i think it is working now BUT sound only appears during login and logout while KDE sends sound to another sound card.

how do i define KDE default sound card?

i tried MENU > system settings > sound > device preference
and placed ‘Creative Alsa Driver X-Fi’ as the first device on every option

any suggestions on how to get sound from kde?

thanks a lot,


just to update.

i have installed Gnome and rhythymbox and it works fine with X-Fi.
configured the sound card and it works.

i would think that it is down to how KDE defines the default sound card.

who someone would be able to help out to define the right output card in KDE.



I have KDE 4.2.3 and to make the X-fi default do the following:

Go to Menu - Aplications - Configure Desktop.
In the general menu click Multimedia (on my pc it’s the last icon on the bottom)
Under ‘Audio Output’ and ‘Audio Capture’ move the X-fi to the top of the list if there is more than one entry.

That should do it. Good luck.

Hello, guys.
And what about sound of video from network? youtube, for example.

I’ve installed driver from Creative site (XFiDrv_Linux_Public_US_1.00), changed device priority in KDE settings. And it works, in general.
But often there is no sound from Kaffeine, and, what worse, never from browser. I’m using Opera 9.64, but also have tried Firefox and Konqueror.

What should I try to do?

Sounds like a issue with multimedia. Try and follow this guide to get your multimedia codecs and programs sorted in OpenSUSE 11.1 and the post above it for OpenSUSE 11.0.

Hope that helps.