Creative Labs Sound Blaster Z - audio card - other choices

I installed ‘opensuse leap 15.5’ and restored all my files on the desktop and laptop. I’m on my laptop now. So, I’ll get any info requests as soon as I can.

I checked and alsa-firmware is installed. Alsa info file created from script.

https://paste.opensuse.org/pastes/b3cfa6ade459

alsa-firmware was installed.

Pulse Volume Audio Control:
configuration or devices → settings for sound blaster z → menu ‘analog 5.1 speakers with analog input’

In firefox, I set pav applications to sound blaster z.

No audio

So you have surround sound? Not just stereo output?

If you truly have surround sound, then the following guide may apply with respect to PulseAudio…
https://wiki.archlinux.org/title/PulseAudio/Examples#Surround_sound_systems

The uploaded alsa-info.sh output reported…

snd_hda_codec_ca0132 hdaudioC2D1: ca0132 failed to download DSP

This is unfortunately a common scenario (if you care to search online). Some examples I found…
https://www.reddit.com/r/SoundBlasterOfficial/comments/i84832/creative_sound_core_3d_ca0132_r3dr3dizzxrzxriae5/
https://bbs.archlinux.org/viewtopic.php?id=251997
Others have reported rebooting (sometimes a number of times) may sometimes eventuate with a working card and this kernel message instead…

snd_hda_codec_ca0132 hdaudioC2D1: ca0132 DSP downloaded and running

Also, in this Manjaro thread it was reported that stereo sound output worked but not surround sound…

I’m not sure that I can offer more here, other than to raise a bug report. Not an openSUSE-specific issue as such.

One final thought: Check the installed firmware. Report back with the output from

ls -la /lib/firmware |grep ct

Sound cards which use the CA0132 firmware require ctefx.bin.

If ctefx.bin (ctefx.bin.xz) is missing, then install with

sudo zypper in kernel-firmware-sound

and reboot.

Yes a ‘5.1’ analog surround sound system.

sub-woofer (hardware disabled)
center
Front Left
Front Right
Rear Left
Rear Right.

Ok, check my other replies as well. Do you also have (wired) headphones to test with?

I have everything listed here in a reference file. I’ll post information when I get the chance.

The monitor speakers I have work. I think I have the lots of the cheap headphone/ear buds. I may have good headphones, but my ears overheat when I use them.

I’ll try them with my sound card headphone output jack and use PAV to set to the headphone jack.

#ls -la /lib/firmware |grep ct
-rw-r–r-- 1 root root 311060 Jul 25 01:12 ct2fw-3.2.5.1.bin.xz
-rw-r–r-- 1 root root 655856 Feb 20 2021 ctefx-desktop.bin
-rw-r–r-- 1 root root 655816 Feb 20 2021 ctefx-r3di.bin
-rw-r–r-- 1 root root 88224 Jul 25 01:12 ctefx.bin.xz
-rw-r–r-- 1 root root 283836 Jul 25 01:12 ctfw-3.2.5.1.bin.xz
-rw-r–r-- 1 root root 3216 Jul 25 01:12 ctspeq.bin.xz
drwxr-xr-x 1 root root 1310 Aug 3 00:27 ti-connectivity

I’m busy with work. So, I’ll do some testing as soon as I can.

Ok, so the firmware is installed at least.

If you have any more information I can gather, let me know.

https://wiki.archlinux.org/title/PulseAudio/Examples#Surround_sound_systems

https://forums.opensuse.org/t/sound-blaster-z-not-working/143115/5

Only what I’ve shared already. From what you’ve posted so far…it is surround sound that isn’t working? Stereo sound (via headphones and monitor speakers) does work?

FYI, Headphones, I couldn’t find them and the tiny ones as well.

Here some images that will help.




If use the above settings SBZ disappears in playback and output devices. As you can see.

If I launch PAV, and switch to SBZ on playback. I get no sound. Sound configuration–> sbz defaults to ‘digital stereo’. If I change that, on all the other tabs sbz disappears.

I edited a system file, noted in this website:
https://wiki.archlinux.org/title/PulseAudio/Examples#Surround_sound_systems

Surround sound systems

Many people have a surround sound card, but have speakers for just two channels, so PulseAudio cannot really default to a surround sound setup. To enable all of the channels, edit `/etc/pulse/daemon.conf`: uncomment the default-sample-channels line (i.e. remove the semicolon from the beginning of the line) and set the value to **6**. For a *5.1* setup, or **8** for a *7.1* setup etc.

default-sample-channels=6

You have to restart alsa sound, but I couldn’t find a simple answer. So, I just rebooted. This had no effect. Also, I checked to see if pulseaudio was running, it wasn’t running, I guess I did the right command.

I’m learning about surround sound as we chat.

Command line ‘alsamixer’, switching to sbz, showed all channels at about 70%. Still no sound.

??

Also, I have the high quality microphone that came with ‘soundblaster z’. So, I can run tests with the microphone plugged into the pci sound card.

I may find or buy cheap headphones to plug into the sound card later, if I can’t find the other set.

FYI…

Yes, and you have specified surround sound in that instance. We know that has problems, but does that sound card provide working stereo sound output when the configuration is chosen. That is the question.

I haven’t seen any evidence online that this sound card is supported with respect to surround sound. That would need yet another bug report IMHO.

PAV → configuration

If it is set at the default, ‘Digital Stereo’. Playing ‘summer rain’ (1h).

PAV – > playback → set to sbz

No sound.

FYI, I found an article about someone reverse engineering the windows driver.

https://www.reddit.com/r/SoundBlasterOfficial/comments/i84832/creative_sound_core_3d_ca0132_r3dr3dizzxrzxriae5/?rdt=37928

Links to

https://www.reddit.com/r/SoundBlasterOfficial/comments/9mm5ad/sound_blaster_r3dr3dizzxrae5_linux_driver/

---------->bug report.

I tried plugging my headphone into the sound card jack. Yes, I made sure it was the right jack.

No effect, I raised the volume very high (120%) and silence.

So, this topic is closed. I’ll post on here, if it’s ever fixed.

Thanks to all for the help. I have most of the webpages archived.