Creating read-only snapshot of default subvolume.Creating snapshot failed

Hello I updated from kernel 6.8.5 to 6.8.9, and X won’t start anymore. So I decided to rollback to the previous snapshot. I have booted into 6.8.5 version, and did sudo snapper rollback, however:

denis@dgecko:~> sudo snapper rollback
Ambit is classic.
Creating read-only snapshot of default subvolume.Creating snapshot failed.

denis@dgecko:~> sudo snapper --iso list
    # | Type   | Pre # | Date                | User | Cleanup | Description            | Userdata     
------+--------+-------+---------------------+------+---------+------------------------+--------------
   0  | single |       |                     | root |         | current                |              
1065* | single |       | 2023-10-10 13:26:17 | root |         | writable copy of #1058 |              
1136  | pre    |       | 2024-04-02 11:12:18 | root | number  | zypp(zypper)           | important=yes
1137  | post   |  1136 | 2024-04-02 11:12:34 | root | number  |                        | important=yes
1138  | pre    |       | 2024-04-14 14:37:07 | root | number  | zypp(zypper)           | important=yes
1139  | post   |  1138 | 2024-04-14 15:35:10 | root | number  |                        | important=yes

i am currently writing this from the 6.8.5, basically I just would like to make it the default, and delete the 6.8.9

You could check the same things as in

I stopped at here:

denis@dgecko:~> sudo snapper -v --debug --no-dbus rollback
constructing ProxySnapper object
executing command
Snapper constructor
snapper version 0.10.7
libsnapper version 7.4.0
config_name:root root_prefix:/ disable_filters:false
loading file /etc/snapper/configs/root
key:SUBVOLUME value:/
key:FSTYPE value:btrfs
key:QGROUP value:1/0
SELinux support disabled
key:SYNC_ACL value:no
subvolume:/ filesystem:btrfs
number of ignore patterns:8
found 6 snapshots
Ambit is classic.
Creating read-only snapshot of default subvolume.THROW: open failed path://.snapshots/1140 errno:2 (No such file or directory)
CAUGHT: open failed path://.snapshots/1140 errno:2 (No such file or directory)
create snapshot failed, btrfs_util_create_snapshot_fd2() failed, errno:2 (No such file or directory)
THROW: create snapshot failed
CAUGHT: create snapshot failed
RETHROW: create snapshot failed
Snapper destructor
CAUGHT: create snapshot failed
Error (create snapshot failed).


sudo snapper get-config
Key                    | Value
-----------------------+------
ALLOW_GROUPS           |      
ALLOW_USERS            |      
BACKGROUND_COMPARISON  | yes  
EMPTY_PRE_POST_CLEANUP | yes  
EMPTY_PRE_POST_MIN_AGE | 1800 
FREE_LIMIT             | 0.2  
FSTYPE                 | btrfs
NUMBER_CLEANUP         | yes  
NUMBER_LIMIT           | 2-10 
NUMBER_LIMIT_IMPORTANT | 4-10 
NUMBER_MIN_AGE         | 1800 
QGROUP                 | 1/0  
SPACE_LIMIT            | 0.5  
SUBVOLUME              | /    
SYNC_ACL               | no   
TIMELINE_CLEANUP       | yes  
TIMELINE_CREATE        | no   
TIMELINE_LIMIT_DAILY   | 10   
TIMELINE_LIMIT_HOURLY  | 10   
TIMELINE_LIMIT_MONTHLY | 10   
TIMELINE_LIMIT_WEEKLY  | 0    
TIMELINE_LIMIT_YEARLY  | 10   
TIMELINE_MIN_AGE       | 1800 


sudo btrfs qgroup show /
ERROR: can't list qgroups: quotas not enabled

So you have exactly the same problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.