Creating Keyboard Shortcuts

Hello All,

I have installed OpenSuSE 12.1 (GNOME Desktop) on a ***HP Mini 110 ***laptop.

The keyboard for the laptop is only an 80-key keyboard due to the size of the laptop, so I’m not sure if that has anything to do with this, but I’d thought I’d mention it.

Basically if I go to System Settings > Keyboard > Shortcuts Tab. Then if I try to create a new shortcut or even modify an exiting shortcut, it does NOT recognize the ctrl key when I use that as part of the key combo.

For example, I created a new shortcut to launch a Gnome Terminal and I wanted to make the shortcut ( Ctrl+Alt+T ) and when I press that key combo it only enters ( Alt+T ) as the keyboard shortcut. I tried using Ctrl+Alt on both side of the spacebar but it does the same thing.

I also tried using a USB Keyboard, but that does the exact same thing as well. Could this be a Driver issue…? I’m not sure what else to try for this.

Any thoughts or suggestion would be much appreciated!

Thanks in Advance,

In KDE4, we can access Input Devices ->Keyboard ->Keyboard Model ->Hewlett-Packard Mini-110 Notebook
Can you access a dropdown menu in GNOME that provides a list of keyboard models?

Why openSUSE 12.1?

Why not 13.1, or at least 12.3?

Follow Up

Select System Tools -->System Settings -->Keyboard -->Click on Layout Settings button -->Click on “English(US)” to make active
Click on Allow different layouts for individual windows
Click on the Options button and select CNTRL key position
Select at Bottom left and place a tick-mark
Click the close button
On the Layouts tab ->Click on the keyboard icon to check the functionality of the CNTRL key

That should do it.

I agree. It should have better GNOME performance including a newer kernel.

Hey Guys, thank you ALL for the replies VERY MUCH appreciated!!

UGHHH… Sorry, I forgot my Mini 110 at the office when I left today. I may have to get back to you all on Monday when I get back in and have the 110 in front of me…
I apologize, I meant to bring it with me, but totally forgot…

The only reason I went with 12.1 was because I already had 12.1 burned onto a DVD… So I figured, what the heck.

This laptop was given to me to be thrown away because the previous user had no use for it anymore *(it was running Windows XP). So I decided to re-purpose *(threw in more RAM and installed OpenSuSE) it for myself for doing “mobile” things around the office. My day-to-day laptop is a Dell Latitude E6510 (4GB RAM, Code i7, 2.8GhZ) which is quite the work-horse for me. When I come into the office I put the laptop onto a dock and if any of you use Docking stations with Linux you know how annoying/difficult it can be to just simply remove the laptop from the Dock to use it somewhere else. That’s where the Mini 110 comes in, so if I need to run somewhere else in the office to do something, like hookup to a router, troubleshooting anything really, I’ll just grab it and go… It’s been pretty convenient so far.

But, I’ll reply back and answer your questions as soon as I get back into the office.

Thanks again guys, much appreciated!

Thanks Again,

Hey Guys, thanks again for the replies. Sorry for the delay replying back to the thread had a busy morning today…


Thanks for your reply, much appreciated. I followed your instructions and when I tested the keyboard layout by clicking the little keyboard button on the “layout Options” page all the key were registering correctly.

So I then went back to the keyboard shortcuts page and went to enter the new shortcut for the Gnome Terminal Launcher as “Ctrl+Alt+T”, but again when I did that I still only see **“Alt+T” **as the shortcut… But for some reason “Ctrl+Alt+T” is the ONLY shortcut that opens the Gnome-Terminal window… Not Alt+T, nor Ctrl+T, just Ctrl+Alt+T… Strange huh…?

I thought since the Terminal one ONLY works when I do "Ctrl+Alt+T" I was thinking that maybe it was working and just not showing the “Ctrl” portion of the shortcut, or something like that… So I went into Custom Shortcuts and added a new one for Gedit. I entered **“Ctrl+Alt+G” **as the shortcut and what displays is “Alt+G”. But for this one, ONLY **“Alt+G” **will open Gedit and NOT Ctrl+Alt+G…

Strange… I know both Ctrl keys are working fine for everything else, like for cut, copy, and paste… And they were working for that as well before I changed the layout, so I’m not sure what is going on with this thing.

QUOTE: Romanator
In KDE4, we can access Input Devices ->Keyboard ->Keyboard Model ->Hewlett-Packard Mini-110 Notebook
Can you access a dropdown menu in GNOME that provides a list of keyboard models?

Yea, I wish I had a section like that in the GNOME setting’s menus… In KDE I’m guessing that menu isn’t in YaST, but a KDE specific settings menu, right? It would be nice if I was able to select the exact model for the laptop, like you seem to be able to do…

Unless a reboot or anything like that was required after I followed your instructions *(which I assume isn’t necessary), is there anything to try?

Thanks Again for the replies, much appreciated!

EDIT: As far as a newer version, would you guys recommend upgrading this laptop to the newest version, even though it is a fairly old laptop…?

Thanks Again,


I just tested GNOME on openSUSE 13.1. The Option feature for the keyboard is no longer provided. GNOME has been updated.
The keyboard is no longer required to be preset for the CNTRL and ALT key combinations. And, a newer updated kernel is also provided with newer features.
Many users of HP laptops find it much easier to set up. Most features are autoconfigured during the initial setup.

I would highly recommend downloading the openSUSE 13.1 DVD ISO. As far as a laptop, buying a newer HP, Acer, Samsung or Lenovo Thinkpad T series would work very well.
Not to mention they will run much faster than the HP Mini-110 netbook. Netbooks are limited in memory, graphics and they run a lot slower.

Good Luck!


Definitely. At the very least, up to 12.3, but 13.1 should work just fine.

Hey Guys, sorry didn’t see that there were anymore replies to this post, till now…

Yea, the only reason I have the Mini-110 is because someone was going to throw it away, and it was still in pretty good shape so I decided to re-purpose it for myself for purely convenience purposes… So buying a new laptop isn’t really an option here. Originally, my plan was to install the existing Windows OS and the OpenSuSE install on separate partitions, but the previous owner of the laptop didn’t have the restore discs, and I attempted to use an XP OEM disc I have, along with the Windows Serial/Key-Code Number on the bottom of the laptop *(so it would have been the SN for the Mini-110), but when I did this it told me it was incorrect and to use the number from the sleeve of the disc… Uhh ohh lol, wrong disc… So at this point *(I don’t remember exactly if it did or not), but if there was any Recovery Partition on the laptop it was wiped out… Dohh! Oh well, that’s when I decided to just install OpenSuSE on the entire HDD…

But anyway, thanks for the info and I think once I have some spare time I’ll try installing 13.1 or whichever is the newest at that time.

Thanks again for the replies, much appreciated!

Thanks Again,