creating dial up using nokia 5200

i use dial up using nokia5200 in suse 11. 1 kde 4 in
yast>network devices>modem shows the phone but in not connected state even when the phone is attached via data cable .whenever i click edit and configure it then another modem set up is created but none of the modem configuration creates connection successfully,
can any one tell how to configure the nokia 5200 phone modem ?
i dial using kinternet

That should work OK. Have a look at this guide, maybe something missing that you didn’t do:
Install Wireless HSDPA broadband in Suse/openSUSE Using Nokia 6120 Mobile Phone

now on dialing via kinternet it gives smpppd error
thnx for reply

Check that you have the smpppd daemon running

will it run through run panel
also can u tell the work of wvdial

Sorry, I don’t understand either of these questions, can you repeat them more words to explain what you mean?

dear sir
as u must have noticed i am new new to linux thus iwant to know abt smppppd daemon and how it can be started(if not already working)
also i ve noticed while configuration something named wvdial what it has to do with it?
hope to see ur answer

smpppd: open Yast → System → System services (runlevels). Enable smpppd to “Yes”
wvdial: dials the phone number

wvdial is a terminal-based equivalent of kinternet and kppp KDE apps.

Thanx all for ur help now i am able to atleast dial the number but the packet data connection still can not be maintained . I think it is because i ve not provided access point . Where should i give it?
As per my research i ve found some code to be given in init3

Thanx for ur support u ve been a great help. Now i ve established the connection and able to use it easily. As per the warning given on the start of kinternet for this i ve just typed wvdial on console as su now its working fine

If you have a su command that needs to be run before the internet connection will switch on, you can put that command is a special text file called “boot.local”. The file is found at /etc/init.d/boot.local. Open it in a superuser text editor and put your command at the bottom. It will be commanded at boot time in runlevel 3 I think.

Due to conflict between grub and vista i had to reinstall the suse all over again . I ve configured modem easily and is successfully getting connected to internet. But there is no exchange of data. Computer is not sending even a single bit. Network is fine .
In the file of kinternet it shows my ip address but for server side it shows server failure “can not configure resolv.config”

It seems the information from the Name Servers provided by your Internet Service Provider is not getting through.

Do you have a configuration screen like this:

yes i get the same screen pls help me out it is becoming a bit frustrating

Your Internet Service Provider (ISP) has two “Name Servers” reserved for you on the internet where your connection will look to discover where on the internet are the files you are searching for in your web browser (like when you link to these forums, the Name Servers tell your browser where to find

You need to code the IP addresses of your ISP’s Name Servers into your computer because they’re not being picked up automatically.

So do two preliminary things and then report back:

  1. Go to your ISP’s website and find the IP addresses of the name servers – two IP addresses
  2. Run this command and return the results: cat /etc/resolv.conf

i ve got one ip from the company

result for the cat /etc/resolv.conf are:

*### /etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:




or disable DNS configuration updates via netconfig by setting:


See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

now can the system be configured???

Well you can test it by opening the file /etc/resolv.conf and putting this line at the bottom:

nameserver a.b.c.d

where you substitute the IP of the ISP’s Name Server for the a.b.c.d.

You can also try these two line instead of that one line:


I can’t recall, maybe reboot after that and then start the internet connection.

How can i edit it . . . . Its denying . . .though i am the root can u give any alternative thnx

Can u think of any any reason that why earlier (in earlier installation ) it was working and now its not