Crash/freeze two or tree times a day


I’m not sure this is the best place to post about this, but here I go:

For a little over a week now, my laptop freezes twice or trice a day. The screen freezes, I can’t even control brightness. Sound (if there is any) sometimes keeps playing for another couple of second but always gets stuck in a ±1 second loop eventually. I’ve once waited for about 20 minutes without noticing any change (not even in fan-noise), but usually I restart as soon as I recognize another freeze. I don’t think I’m doing anything special that might cause the freeze.

Two times the screen only froze for a short while and then switched to text mode, displaying a call stack and restarting about a minute later. The second time I was able to take a picture (see Because these crashes are different from the ones I’m having most often, I’m keeping in mind that there may actually be two problems.

Once the caps lock LED started blinking when my computer froze, but it usually doesn’t

During the freeze my laptop does not respond to:

  • brightness (fn-key combination)
  • ctrl-alt-backspace twice
  • ctrl-alt-f1 (or f2, f3, f4, f5, f6, f10)
  • volume, not even the red keyboard light when I press mute
  • pressing caps lock does not change the caps lock-LED
    But it does respond to:
  • cd drive open/close
  • two-tone sound when (un)plugging power
  • keyboard lighting (fn-key combination turns on/off a white LED next to my webcam lighting my keyboard)
  • hold power button…

How far I’ve come trying to fix this:
I have checked logs in /var/log/, but the last entries before the reboot don’t show anything about a serious problem. If you want to see for yourself, ask me for the logs.
I have run memtest86+, but it couldn’t find any errors.

I’m suspecting FlightGear 3.4.1 from repo home:lemmy04 – I believe my first feeze was soon (1 or 2 hours) after I installed the newest version of FlightGear, during running flightgear. Though, I have not run flightgear for a week and the freezes are still happening. I’ve checked what packages are installed from home:lemmy04, and removed two “intel-e1000e*” packages, which I didn’t think I needed. The calltrace mentioned “e1000e”, so that package might have caused my problems. I ran zypper ps to see if I had to restart anything, but no processes using deleted files were found, so I didn’t restart. Sadly about an hour later my computer froze again, and I decided to post about my problem.

  • Maybe the problem is solved now I’ve (unvoluntarily) restarted my laptop for the first time after removing the intel-e1000e* packages. I haven’t had a second freeze yet, but I’m expecting my next freeze tomorrow: I’ve had 3 today already.
  • Maybe there are actually two problems and the problem causing the two “freeze->text mode/calltrace->auto restart”-crashes I had last week is now solved, leaving me with the far more frequent “freeze.”-crash.
  • Maybe the problem is still there, and I’ll have two or three crashes again tomorrow.
    I’ll update when another freeze happens, or when I haven’t had any freezes by tomorrow evening (European time).

Another thing that happened around the same time and might have something to do with this: in System Monitor (ksysguard) the graphs for network history and CPU history are not showing.

Can anyone help me find out what is causing this?
Let me know if you need logs, hardware info, software info or anything else.

> uname -a
Linux 3.16.7-24-desktop #1 SMP PREEMPT Mon Aug 3 14:37:06 UTC 2015 (ec183cc) x86_64 x86_64 x86_64 GNU/Linux

On 2015-09-20 01:16, kroppyer wrote:

> Once the caps lock LED started blinking when my computer froze, but it
> usually doesn’t

That’s the kernel signalling that it entered panic.

Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Run and keep open some apps that report real time metrics.

top (and variants of top) is popular to display things like CPU usage, load distribution and more, Memory usage. If you’re running KDE, there are various desktop applets that can report some metrics in real time.

Although running a real time monitoring app (or more than one) will add a tiny load to your machine, it usually won’t be enough to make a difference.

In particular, understand how memory reporting metrics works. Although you can see the same reported in top, IMO my writeup on “Free” is relevant to understand how memory and memory buffers are used and reported (overall usage).

Note the command I describe in my “Free” article that clears memory buffers. If you’re switching from one set of heavy tasks to another, then it’s something you should do to force freeing up memory for your game.


On 2015-09-20 03:06, tsu2 wrote:
> Run and keep open some apps that report real time metrics.
> top (and variants of top) is popular to display things like CPU usage,
> load distribution and more, Memory usage.

It could display on another computer. When it crashes, you see what it
displayed last.

Or the kernel logs can be sent to another computer real time. Best over
a real serial port, but can be done with standard network.

Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Thanks for the reactions. I am currently logging the output of top. I’m pretty sure this will show that there is no excessive memory or CPU usage preceding the crash, but who knows.

“Problem” is, I’ve not yet had a new crash. I should’ve had one or two already. I guess a restart really was required after removing intel-e1000e and intel-e1000e-kmp-desktop, and now my problem is fixed. I’ll keep logging top for bit more, in case todays crash is just delayed a bit :slight_smile:

flightgear seems to work fine without the e1000e packages, though I haven’t had the time to really test that.

Intel drivers are built into kernel no need for a second one to be installed. probably root of your problem