Crash/freeze on closed lid

I’m using oS 11 GNOME on hp compaq 6710b (updates installed). When I close the lid system completely freezes/crashes (had the same problem on hp compaq nx7300). When I installed oS and set gnome-power-manager lid_ac=nothing (in gconf-editor), everything worked perfectly fine. After first crash I set suspend=nothing (this worked before in nx7300, but not in 6710b), then tried disabling desktop effects, changed various settings in gconf-editor>apps>gnome-power-manager, echo’ed 1 into /proc/acpi/video/*/DOS and added “blacklist video” line to /etc/modprobe.conf.local as suggested in bugzilla (, but still no effect - on closed lid oS hangs on irregular basis (!?). I found similar thread in applications area, but its not a gnome or kde specific issue, so I’m posting this here. It’s a known bug, but there’s still no known workaround, so, perhaps somebody managed to fix it or have any idea of what may be the cause and suggest some solution? Thanks.

I’ve same problem, my workaround is simple, with a pencil push the lid switch and screen comes back.

Hope work for you.


Juan Camilo Yanquen

no… it won’t help. system hangs completely. but thanks anyway :slight_smile:

Quite some time passed.

HP 2710p
openSUSE 11.1 (x86_64)
Intel GM965.

Same freezes on lid close.

Have you tried messing around with your bootup options. I would try noapic, nolapic, irqpoll, and combinations of those. acpi=off might also help, but you would probably lose your hibernate and suspend. Just a couple of suggestions. Good Luck.

I have the same problem on an Acer Aspire one 110 running opensuse 11.1.

I have also filled a bug report, but there is no solution yet.

Loosing hibernate and suspend is not a good thing,
but I’ll try all the options.

Thanks for the tip, PenguinMigrations!

For the moment the problem disappeared completely
with some update from X11:/XOrg repository.
But with another update it came back…

And the last update breaks X due to missing
So I’m with old XOrg packages now,
and will wait for the fix in X11:/XOrg.
Then will try testing again with new packages.

X11:/XOrg repository packages were fixed.
So I updated to the newer version,
and ‘closed lid’ problem disappeared.