Crash during zypper update - "Unexpected Inconsistency"

So I was trying to keep things up to date (using 11.2) and in the command line typed

zypper update

I said yes to adding / installing whatever packages came up. While this was going on I’m not sure if my laptop overheated and shut off, or if there was a crash that shut the laptop off. Completely off.

Something like this happened once before while installing Debian on this laptop, but I’m almost positive it was due to an overheat.

Anyway, when I rebooted the laptop just shut off twice… then when I let it sit there a bit and came back I only had a CLI… I wrote down some of the output…

Activating swap-devices in /etc/fstab   failed

fsck failed.  Please repair manually and reboot.  The root file system is currently mounted read only.  To remount it read-write do:

bash# mount -n -o remount, rw /

Attention: Only CTRL-D will reboot the system in this maintenance mode.  Shutdown or reboot will not work.

Give root password for login:

So I gave my password, logged in, and typed exactly what it told me to…then hit CTRL-D. It rebooted, but I got the same set of errors. Unexpected inconsistency, etc…

Did I enter that command wrong? How do I begin to trouble shoot?

Any direction is really appreciated. Thanks.

So, you need to download and create a LiveCD boot disk, like the one for GNOME and boot from it. You can then use the GPARTed partition program to FIX any existing problems on your laptop. The SWAP file, in particular could even just be deleted and recreated, in the same place, if need be. Most often, such a problem can occur if for some other reason, your computer just shuts down, which could be something else entirely.

FYI:

By the way, the Packman repository may be off line for up to a week and most users might be advised to just disable it until this time period has expired. Further, you may need to redo completely (as in delete and re-add) any entries for Packman as they are redoing the whole thing.

Thank You,

The only time I’ve seen that particular error come up was on a virtual machine where the host machine (a Windows box) had locked out the virtual drive somehow. On a physical machine, that doesn’t bode well: you could have serious hardware failure. The update may have had nothing to do with it, other than increase the read/write load on the disk that broke it finally.

The only other explanation could be a kernel update that messed up your boot partition. Do you know if there was a kernel update pending for 11.2?

If not, you may be in trouble. Where is that backup disk again?

Thanks for the replies…

jdmcdaniel3 - I’ll try booting off the live cd and working with the partitions.

twelveeighty — I hope it’s not a hardware issue…for obvious reasons. Windows is booting just fine now, though…

If nothing else, I’m learning from this experience. :beat-up:

SOLVED:

For anyone else that may have this issue… which I’m almost positive was a result of the power going off on my laptop…

I booted from a Live CD. Then I used the GParted partitioning program. I right clicked on the damaged partition, clicked “check”. *(Edit: “Check” option will check AND repair.)*The task is listed in the bottom window pain. Just click “Apply” to get the process started. Once it was done, I restarted and OpenSuse was running just fine.

Thanks everyone for the help.

On 2011-02-21 03:36, a2ice wrote:

> Code:
> --------------------
> Activating swap-devices in /etc/fstab failed
>
> fsck failed. Please repair manually and reboot. The root file system is currently mounted read only. To remount it read-write do:
>
> bash# mount -n -o remount, rw /
>
> Attention: Only CTRL-D will reboot the system in this maintenance mode. Shutdown or reboot will not work.
>
> Give root password for login:
> --------------------
>
>
> So I gave my password, logged in, and typed exactly what it told me
> to…then hit CTRL-D.

Wrong!

> It rebooted, but I got the same set of errors.
> Unexpected inconsistency, etc…

Obviously.

It is not telling you to “mount … etc”, it is telling you to “Please
repair manually and reboot” - way different. So do it! Repair your partition!

>:-)

Exactly what you did later with the live CD, but without it. Typically,
fsck /dev/something.

The “/dev/something” you have to deduce from the text above what you posted.

The “mount…” command is what you use if the partition is fine, but there
is an error in the configuration, like fstab listing the wrong device. In
that case, you need rw access to the partition.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Thanks, Carlos. Hopefully there won’t be a “next time” anytime soon, but should I have that issue, I’ll use the fsck command.