cpufrequtils not working in openSUSE 13.1 for some reason ...

With the release of openSUSE 13.1, I have three bash scripts that do not work properly with CPU speed, but I am unsure of the exact problem. Here is the bug report I made:


Here is problem bash script 1, works in openSUSE 12.3, but not 13.1: C.F.U. - CPU Frequency Utilitiy - Version 1.10 - For use with the cpufrequtils package - Blogs - openSUSE Forums

Here is problem bash script 2, works in openSUSE 12.3, but not 13.1: S.A.K.S.I. - SUSE Automated KDE Sysinfo Installer - Version 1.0.0 for openSUSE 12.3 - Blogs - openSUSE ForumsHere is problem bash script 3, works in openSUSE 12.3, but not 13.1: H.I. Hardware Information - A Bash script to install and run inxi with default options! - Blogs - openSUSE Forums

I am not sure that cpufrequtils is the culprit really, but if not, then what might be wrong? Any help will be appreciated with issue before openSUSE 13.1 comes out.

Thank You,

When you say works in 12.3, do you mean with the default kernel? or did you also have them work with later kernels?

Recall: http://forums.opensuse.org/english/get-technical-help-here/pre-release-beta/488451-kernel3-10-has-big-problem.html#post2569870

From your bug report, you can clearly see that the p-state driver is in use now with 13.1 (as expected, given extension/adoption of it for haswell processors in the 3.11 kernel). I would not expect cpufreq utils to work with such

So what is interesting is all looks normal in openSUSE 12.3, while not in openSUSE 13.1 and the kernel version does not matter as I have tried the default, 3.11 and 3.12 where only the openSUSE version seems to matter. For bash script I could move to use lscpu for info, but not sure what to do with my bash script CFU for instance to read CPU speed or to set the governor. I do recall a kernel change due to the change in the CPU speed control, but I am not sure what the change really means.

All comments are helpful and appreciated.

Thank You,


For bash script I could move to use lscpu for info, but not sure what to do with my bash script CFU for instance to read CPU speed or to set the governor.
To read the speed you could use/cat cpuinfo … cat /proc/cpuinfo → e.g.: “watch grep “cpu MHz” /proc/cpuinfo”

To set the governor you should be able to echo the sysfs governor value.

For reading interest:

In openSUSE 12.3, the terminal command:

watch grep \"cpu MHz\" /proc/cpuinfo

Is providing a correct output of around 1700 for all four cpus,


but in openSUSE 13.1, here is what I see:


All showing random cpu speed readings …

Thank You,

So, do you think the 13.1 values are simply erroneous, or do you think the cores are actually ramped up to those speeds? (any indication? noisy fans, temps etc)

What happens if you disable the pstate driver and utilize the acpi driver instead?

So somehow the max turbo cpu boost speed of the i5-3317U CPU is having an effect, said to be 2600 MHz for my “Intel(R) Core™ i5-3317U CPU @ 1.70GHz” a Ivy Bridge cpu. I do not or have not tried to enable the pstate.The latest tests were made using kernel 3.12.

Thank You,