CPU Scaling

I did a little research and found that my machine runs cooler when i set the cpu scaling governor to conservative instead of ondemand. Everything is fine after I type ‘echo “conservative” > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor’ until I reboot the machine and the governor is automatically set back to ondemand. I can’t seem to find where to change what is the default governor. Is it maybe somewhere in the boot scripts? If so I don’t know where. It is a lenovo t61p laptop. Any help would be greatly appreciated

                               mike

Mike,

try /etc/sysconfig/powersave/cpufreq
Note that for this setting to take effect, you need to disable the powersave demon running on top of your GUI, like kpowersave.

Uwe

Thanks, I set CPUFREQ_CONTROL=“userspace”. It set the governor to “userspace” but it seems to be behaving the same way as “conservative” because HAL is controling the cpu speed.

thanks
Mike

Mike,

I had a problem with cpu scaling using gnomes cpufreq-applet yesterday. Here is a how-to post I made on how to fix it:
[How to fix gnomes cpufreq-applet]](http://forums.opensuse.org/hardware/laptop/387052-how-fix-gnomes-cpufreq-applet.html)

Just for reference, this is on a Dell Latitude D620 with an Intel Core Duo Processor.

Hope this helps,
Antiparadigm