CPU-FREQ how to user select cpu speed?

I’m running SuSE 11.1 here with the Gnome desktop.
I noticed that the ability to change the CPU stepping is set to “ondemand” all of the time.
I would like to be able to change this to “performance” once in a while.

Is that feature just disabled from this version of the applet?



It is configured in the powersave app from the panel

Regular click on the cpu speed icon provides nothing.
“right click” from the mouse give me preferences.

set to dynamic in prefs

that is how is should be, I know. Scaling works. However, the choice dialog does not pop up when clicked that allows it to be changed to “performance, dynamic, powersave, ondemand”.

That is my problem. When I mouse over the applet, it is set to “ondemand” all the time.
It’s as if the package was compiled without that available to the user.


Create a second power profile indentical to one usually active with only a change in CPU policy and you can select it there? http://thumbnails2.imagebam.com/2446/8fc1a224450341.gif](http://www.imagebam.com/image/8fc1a224450341)
(Or is this only available in KDE 4.2?

I’m running Gnome 2.24…

I am blind :), my apologies, must have mixed it up with another topic open in another tab.
Can’t advice about Gnome as I am not using it.

I found another post, so tried the command shown here. It seems to work for root, but not for a regular user…still seems like a permission problem.
linux-5w0k:/home/robert # cpufreq-selector -g performance
linux-5w0k:/home/robert # cpufreq-selector -g powersave
linux-5w0k:/home/robert # exit
robert@linux-5w0k:~> cpufreq-selector -g ondemand
You must be root

Just thought I would post that this has been resolved.
thanks for the help.
I found a link here

I did perform a fresh installation, but it was from the live cd. perhaps that had something to do with it.

The command that fixed it was:
$ su
$ chmod 4755 /usr/bin/cpufreq-selector