CPU cooler runs almost constantly

Hi,

I’ve bought a new laptop and installed openSuse 12.3 on it.

My problem is that the cpu cooler is running almost constantly and driving me crazy.

when running sensors i get the following output:

acpitz-virtual-0
Adapter: Virtual device
temp1: +55.8°C (crit = +158.8°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0: +54.0°C (high = +87.0°C, crit = +105.0°C)
Core 0: +54.0°C (high = +87.0°C, crit = +105.0°C)
Core 1: +47.0°C (high = +87.0°C, crit = +105.0°C)
Core 2: +47.0°C (high = +87.0°C, crit = +105.0°C)
Core 3: +48.0°C (high = +87.0°C, crit = +105.0°C)

and as such the temperature is not alarmingly high. Besides the CPU is mostly sitting idle - according to top 96% idle.

Yet, the fan is running…

Output from sensor-detect:

.
.
AMD Family 15h thermal sensors… No
AMD Family 15h power sensors… No
AMD Family 16h power sensors… No
Intel digital thermal sensor… Success!
(driver `coretemp’)
Intel AMB FB-DIMM thermal sensor… No
VIA C7 thermal sensor… No
.
.

Some Super I/O chips contain embedded sensors. We have to write to
standard I/O ports to probe them. This is usually safe.
Do you want to scan for Super I/O sensors? (YES/no):
Probing for Super-I/O at 0x2e/0x2f
Trying family National Semiconductor/ITE'... Yes Found ITE IT8518E Super IO’
(no support yet)
Probing for Super-I/O at 0x4e/0x4f
Trying family National Semiconductor/ITE'... No Trying family SMSC’… No
Trying family VIA/Winbond/Nuvoton/Fintek'... No Trying family ITE’… No

Is it because of lack of support of the ITE IT8518E Super IO?

Otherwise, how can i change this behavior?

Please let me know if you need more information.

Best regards

Kim

On Mon, 29 Apr 2013 17:46:01 +0000, kimg123 wrote:

> Please let me know if you need more information.

The make/model of the laptop would probably be useful.

I doubt the lack of a sensor is going to cause the fan to run
constantly. One thing I have noticed is that in some cases, the ATI
video driver causes the fan to go nuts on my wife’s laptop. Reinstalling
the driver has resolved that for us in the past.

Jim

Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Basically, the laptop is a ‘no name’ brand.

Advantage is that i can buy it without an OS installed.

the CPU info (i’ve just included info for one core out of 8. they all contain almost the same info):


processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 58
model name : Intel(R) Core™ i7-3740QM CPU @ 2.70GHz
stepping : 9
microcode : 0x17
cpu MHz : 1200.000
cache size : 6144 KB
physical id : 0
siblings : 8
core id : 0
cpu cores : 4
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_pe
rfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt ts
c_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms
bogomips : 5387.93
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:


It contains a 750Gb HD and 500Gb SSD disc and 32 Gb Ram.

Except for the noisy fan it runs like a dream. Really makes Suse appear cool and nice.

Kim

Are you sure it is the CPU cooler?

What graphics chip does it have?
If it’s a newer AMD you should try to install the proprietary fglrx driver. (the opensource radeon driver is known to cause noisy fans on some models…)
See: https://en.opensuse.org/SDB:AMD_fglrx

The graphis adapter is a GTX675m - GeForce GTX675mX 4GB .

I’m just guessing that it’s the CPU fan. It might as well be the GPU fan.

I really don’t know. But it’s a fan…:slight_smile:

kim

In this case you could try the proprietary nvidia driver:
https://en.opensuse.org/SDB:NVIDIA_drivers
(you would need the G03 driver)

I don’t know if it helps but it’s worth a try. The proprietary drivers do have better support esp. for the power management.

On Mon, 29 Apr 2013 18:56:01 +0000, kimg123 wrote:

> Basically, the laptop is a ‘no name’ brand.

Where did you get it from? What are the hardware specifications?

It’s really difficult (nearly impossible) to provide advice without
knowing some specifics about what’s inside the system. Anything would
just be a stab in the dark in the hopes of finding the right combination

  • but knowing (for example) that it uses an ATI video controller vs. an
    nVidia, Intel, or some other - that’s useful information.

As detailed as you can be about component brands will be helpful. The
size of the hard drive and amount of memory really doesn’t give us
anything to go on. Nor really does the cpuinfo output - we know it’s an
Intel CPU, but nothing about what that CPU is plugged into (and that’s
usually the differentator).

Jim

Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

All Nvidia 6XXM chips are Optimus capable, whether that’s enabled on a specific card is vendor dependent, so what does this command say?

/sbin/lspci | grep VGA

Just a thought: have you tried adding “acpi_osi=Linux” to the grub options?

Hi,

Maybe your problem is the same as here:

forums.opensuse.org/english/get-technical-help-here/laptop/482223-high-fan-throttle-after-resume-suspend.html

you should also look at this:

https://bugzilla.novell.com/show_bug.cgi?id=805410

that means there were a problem in new kernels (from 3.7) with fan control. Now is solved in kernel 3.8.12 and 3.9.1

the following is the kernel bug and the corresponding patch.

https://bugzilla.kernel.org/show_bug.cgi?id=56591

It seems kernel 3.7 is not going to receive new patches so i don’t know if openSuse will create it’s own to solve this problem

hope this could help.
Miguel