CPU can't reach its maximum frequency


**The problem
**CPU can’t reach its maximum frequency. It can only scale up to 1.92GHZ, as reported by

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq

and cpupower -c all frequency-info

It affects all cores

**Some Information
**Lenovo G400s (Link in spanish, but it has the specs)
CPU Model: Intel(R) Core™ i3-3110M
Max Freq: 2.4GHZ as reported by lscpu and cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq
Min Freq: 1.2GHZ as reported by lscpu and cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_min_freq
Kernel: 4.5.0-3-default
Governors: performance, powersave
Driver: Intel_pstate
This problem is not present in Windows 10. It reaches 2.4GHZ
This problem is present in Manjaro (kernel 4.4.4). Stuck in 1.92 GHZ too

Things I have tried
**#cpupower -c all frequency-set -g 2.4 GHZ : Doesn’t work

echo 2400000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq : Doesn’t work. It remains at 1920000 without changing.

Using performance governor: Still stuck at 1.92GHZ


When using Ubuntu Mate 15.10, which has a 4.2 Kernel, the cpu is capable of reaching its maximum frequency, 2,4 GHZ, configured with cpufreq -c0 -d 2.1GHZ

This makes me think the problem happens because of something in the 4.5 Kernel?

Should I make a bug report?


  1. Are you sure you’re loading the CPU sufficiently?’
    Also, are you familiar with common “best practice” benchmarking practice which includes among other things that you need to be very careful about the beginning and “pre-” state of your machine before you running standard tests?
    And, that you may need to run a number of tests to suss out any possible idiosynchrosies?

  2. Today’s Intel CPUs of course have their own automatic power levels, similar to an automobile automatic transmission. You may not have complete control over whether the CPU will “down shift” – The best you may be able to set is to manually disable any system power settings that are available to you which will still only have an undetermined effect.

  3. I’d have no idea whether different kernels implement or influence hardware CPU settings differently, it may actually be quite complex. So, what you observe might not actually be an issue. I’m going to throw out a wild possibility that the 4.5 kernel might contain some radical changes that improve processing over the 4.2 kernel so you haven’t loaded your 4.5 kernel fully.

  4. Perhaps your current focus on max CPU frequency isn’t most advisable. Perhaps it would be better to benchmark measuring application performance instead (This is what is normally tested and published).

  5. Of course, it might also be that either sensor data is incorrect or there is a limitation in the 4.5 kernel that really does make it work less well than other kernels. But, only proper testing can determine the truth.

IMO and HTH,

Thanks for responding, tsu.

1.No idea. My test consist of installing a distro in a 25GB partition, which I use to **** around, install steam, run Amnesia, a game, and print the frequency for a while

  1. Blaming the Kernel was a random guess I made, based on a post in the arch forum. It was a year old, I think, I lost the link, and it was solved with a kernel update

  2. Maybe.

  3. This is way out of my league

At the end of the day, this doesn’t really affect me at all. I just feel better seeing the numbers match