cp210x USB to UART, USB_UART==ttyS0==COM3

USB to UART device I have

I’m quite new to Linux. I’m trying to “talk” with routers*. But I don’t know how to get openSUSE to know USB_UART<->ttyS0<->COM3… or however you get from one end to the other… ttyUSB0?

I installed minicom, but it’s not “seeing” anything. Downloaded CoolTerm but it’s not well documented in Linux. I could not get CoolTerm to run. And for that matter, minicom is a little confusing about set up.

Anyone know of a good how-to/tutorial? I can find lots for WindBlows, but it seems like all the Linux ones I can find ass-u-me you know what you’re doing.

HANDLE hMasterCOM = CreateFile("\\\\.\\COM3",

The tutorial tells you what each part means, but not what to do with the text.
Do you put that into Command line/terminal? A file, if so, where?
Dose \\.\ == xxxx.xx ?

*The list is long, and each one has different ways of “talking” with it.

Hi and welcome to the Forum :slight_smile:
I use them here to connect to RPi3’s,

Bus 001 Device 003: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port

Add your user to the dialout group via YaST users, you need to logout/login. Once that’s done open a terminal and start minicom. Now press ctrl+a+z keys to pop open the menu, press o for options and then use arrow keys to get to Serial port setup, press enter, again use arrows/lettert to configure (I use /dev/ttyUSB0 for serial device). When done either save setup as dfl so when you start minicom it will use those settings.


Thank you so much


I think there’s a hiccup. When I open minicom I go off-line. WiFi is a USB stick.

Also, ctrl+a+z dose nothing. I got into setup with sudo minicom -s and then was able to finish setup.

No code came thru when I rebooted the router. I don’t know if the router is bricked or dead-dead. I get the right flashes, like it’s trying to boot, and then a steady flash from power.

P.S. lsusb gave me quite a few answers, including the UART. But it dose not tell me where it “put it”

You need to run minicom as your user and create a new ~/.minirc.dfl file, if your loosing your wifi then it sounds like you configured it incorrectly to use USB0 instead of ttyUSB0…

I have;

cat ~/.minirc.dfl 

# Machine-generated file - use setup menu in minicom to change parameters.
pu port             /dev/ttyUSB0
pu baudrate         115200
pu bits             8
pu parity           N
pu stopbits         1


I made a n00b mistake. I attached Rx to Rx and Tx to Tx… This is about the only time, other than CAT5, that you have to make a cross over.

Thanks for your time… for some reason I can’t click the star, it says I have to spread it around???