cp files off cd

Hi

How do I copy files of cd I tryed this
cp /media/cdrom/baseq3/pak0.pk3 /usr/local/games/quake3/baseq3 but not worked any
ideas

Thanks

Does the cp command give any error when you try and copy files?

Did you attempt the copy with root privileges?

sudo cp /media/cdrom/baseq3/pak0.pk3 /usr/local/games/quake3/baseq3

it says

cp: cannot stat `/media/cdrom/baseq3/pak0.pk3’: No such file or directory

I put su -
password
nautilus

Is that right?

On 02/16/2011 11:06 PM, buff3r wrote:
>
> How do I copy files of cd I tryed this
> cp /media/cdrom/baseq3/pak0.pk3 /usr/local/games/quake3/baseq3 but not
> worked any

do you really wanna copy those files to a system directory? (i ask,
because that that is the way to install Quake to openSUSE)

but assumming you do want to copy, then just remember that regular
users usually have no access to system directories, so root has to do
it…so just after you open that terminal become root with this magic


su -

and give root’s password when asked (you will not see what you type)
then that code above looks like it should work.
alternatively you could type this


sudo cp /media/cdrom/baseq3/pak0.pk3 /usr/local/games/quake3/baseq3

it too will ask for root’s id…

if you use su - you need to REMEMBER to log root back out (or just
close the terminal)…but if use sudo root is only active for that
operation…


DenverD
CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

Silly question maybe, but did you mount your CD on /media/cdrom? Can you ls that directory?

This is self-explanatory. Is the path/filename correct?

ETA:
A permission problem would have given you “Permission denied” :wink:

I tryed sudo cp /media/cdrom/baseq3/pak0.pk3 /usr/local/games/quake3/baseq3 not work
I tryed su - no go

Is it because I opened my terminal on my desktop ?

Maybe as @ken_yap said the CD is being mounted somewhere else?
What is output of the


mount

command?

you mean in home folder I see the disc I pressed the little like eject key and now see the file

I do have 2 dvd drives in

When you have the CD in the drive go to the terminal and write the command:


mount

and press [ENTER]. Then post the output of that command here in code tags like this guide explains:
Posting in Code Tags - A Guide

Post the output of

mount

ETA: Beaten to it.

/dev/sdb1 on / type ext4 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
devtmpfs on /dev type devtmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,mode=1777)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
securityfs on /sys/kernel/security type securityfs (rw)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
gvfs-fuse-daemon on /home/puff3r/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=puff3r)
/dev/sr0 on /media/QUAKE3 type iso9660 (ro,nosuid,nodev,uhelper=udisks,uid=1000,gid=100,iocharset=utf8,mode=0400,dmode=0500)

Try this then for copy:


sudo cp /media/QUAKE3/baseq3/pak0.pk3 /usr/local/games/quake3/baseq3

puff3r@linux-lc2e:~/Desktop> sudo cp /media/QUAKE3/baseq3/pak0.pk3 /usr/local/games/quake3/baseq3
root's password:
cp: cannot stat `/media/QUAKE3/baseq3/pak0.pk3': No such file or directory
puff3r@linux-lc2e:~/Desktop> 

Shouldn’t even need the sudo, it has been mounted with files owned by him, see the uid=1000 in the mount output.

@OP: re file not found. Don’t guess that the file is there with that name. Explore the CD directory.

I look and file is on cd in QUAKE3/baseq3/pak0.pk3

Use the GUI file explorer to copy it. The filename may have some characters you mistyped. Maybe you typed capital O instead of digit 0 on the command line.