Counter-Strike Source and Wine

So i recently got opensuse (64 bit) installed and i decided to get steam and source. They both installed fine through wine and i started the game up.

Now heres the bit where i got confused… I ran it (with default “medium” settings) and got around 10-20 fps. OK, i thought maybe if i just put all the settings on low, run it with -dxlevel70, i might get a bit more fps for it to be playable.

So after making all the adjustments, i joined the same server and got the same fps (10-20.) I was just about to give up when i decided i’d try the game on all high settings, including hdr bloom. I joined the server again and ended up with the same fps but of course the models and landscape was more shiny with the hdr.

tl;dr version : No matter what graphics setting i run CSS on i get the same fps.

I have also disabled vsync and aa through the nvidia manager.

Here are my system specs:

CPU: AMD Athlon 64 X2 4000+21.GHz Socket AM21MB
RAM : Corsair TWIN2X 6400C4 DDR2 2048MB
Graphics Card: NVidia GeForce 8500GT 256MB (linux drivers version : 173.14.12)
Sound: Creative SB Audigy (I’m using alsa according to the registry in wine for sound)
Monitor: Acer 19" LCD AL1916WAs

Before I forget, when I’m running the game in windows i get 100 fps.

Thanks to any replies:)

Fixed it by turning off pixel shading and running steam in its own x-server. Works like a charm now;)

I’ve just got Steam to load (using layOnLinux) and am currently downloading CS: Cource now. Fingers crossed! I feel I might be opening a new thread soon! hahaha

I’ll remember the pixel shading when setting up everything.

Dont forget when your turning off pixel shading to also ,under the graphics tab in winecfg, enable “emulate virtual desktop” aswell. Really helps out with the fps.

Good luck!

Okay, I have some problem. I am installed Wine and Steam. I tried install CS:S. Now I have problem: When I click “Start CS:S” button, in my screen come “startimage” (two guy). What I can do?
I have openSUSE 11.1.

Sry bad English. :slight_smile:

I installed CS:S on my 11.1 64bit a few weeks back but gave up due to poor fps performance.

I will give these tips a go, thanks!

Make sure you disable all desktop effects before running any 3d games, and you might also want to run them under KDE3 rather than KDE4.

You will get a much better frame rate, I do under all 3d games.

Not much of a solution I know, but I bought CrossOver Games from Codeweavers.

It’s a little pricey at €37, but it runs the HL2 family of games really well and fast.

I tried pure WINE, Cedega, PlayOnLinux, and Crossover. And Crossover came out the best.

I’m not advertising for them, but here is the link if anyone is interested:

Windows Games Seamlessly Integrated on Mac or Linux - CrossOver Games

Of course you can try it and run it free of charge, but the “bottle” that you install in will stop working after 7 days.

Codeweavers directly support the WINE project, so if you are considering buying, you know that your money is going to a great cause.

A certain other emulator vendor mentioned above gives nothing back to the people who provide them with the heart and brains of their wares, so I really recommend avoiding them.

“C” what I mean? ;).

Also there is a newer version of the Nvidia driver, maybe give that a go. Mine is version 1.80.22, 173 is very old.