Couldn't save files cause /tmp is full, booting to black screen, can access console login though

What things can I do to get back to desktop again? I tried downloading some things and was getting error popups I couldn’t cause tmp/ was full. So at reboot got black screen, did Ctrl alt F1 to get console login. Made way to /tmp directory with “Cd” and removed files in there: rm -r /tmp/*

Didn’t touch anything else. But tried getting out put of partitions that were full, saying system-root under dev/mapper was 100% 9.7G. Was only one saying it’s 100% full. During original installation I left installer do the amounts/sizes for things. What’s best practice for size allotment? I have 1TB hard drive … and it’s now full in root? Lol. I have movies etc in /Videos folder, but that shouldn’t affect the /tmp directory right?

What things can be done to clean up from the console login and to keep files? I’d hate to lose the videos and etc… Also what’s best sizes or amounts during install for things so I know next time? 900 some GB for /root or half of 900GB to /root and /home?

Anyway, can’t access desktop now, get black screen after entering passphrase for lvm encryption screen, can get to console login doing Ctrl Alt F1… what now? Lol How to mount USB stick, find it, and move files to it in Console Login?

I managed to also remove files / empty things in these directories: /var/tmp/, /var/cache/zypp/
still no go… I then found out how to mt usb stick and moved videos and firefox bookmarks.html to the usb stick… so now I can move those to another tower. Really there wasn’t anything else on tower to lose… so guess time to wipe / and reinstall again for 1,000,003 time lol. Guess next time around in installation, make /root and /home about 400 some GB each… Lol. I dunno…

Well with default BTRFS file system recommended root is 40 gig (to allow for the snapper program) with ext4 20-30 gig is just fine. 400 gig for root is a waste unless you have a special usage case.

Yeah, I don’t use BTRFS, I use ext4 and normally it gives me 40GB during installation for /root, 2GB swap, 889.50GB for /home or some such. It’s weird how all the sudden I’m maxed out and couldn’t even download and save photorec / testdisk to Downloads folder, and that’s not even a 2mb download I think.

Got error popup from Firefox about how my /tmp folder was maxed out. I ran that command to display which partitions were full or whatever and it showed dev/mapper system-root as being 100%. Weird too though, cause usually in installation process for making own partition setup, I choose ext4 for all of the partitions, and the “take snapshots” is still checked, I can’t seem to uncheck it.

I’m wondering if the snapshots are/were taking up tons of space. I couldn’t access the logs at the time, or didn’t think to check them from console login screen. I really didn’t download and install many applications though either, so something ain’t right. I do run zypper dup, zypper update, etc quite a bit though to get updates and such.

Maybe there’s tons of left overs I didn’t get removed? “zypper clean” more often or whatever command it is? Lol. Usually I install BleachBit to help remove clutter and junk, but not sure how BleachBit works in Leap 42.1… Should I try making /root 60GB instead of 40GB? Or maybe even 100GB? Lol.

Perhaps the /tmp cleaners on reboot isn’t working right (cron jobs or whatever they are)? I didn’t enable or edit any of those files, not sure which ones or how yet, I’ve seen some threads about it though. But people are all over the place about it so it’s confusing lol.

No snaps in ext4 just in BTRFS and you indicated a 9.7 gig root which is way too small except for very special restricted usage

BTRFS is the default file system these days you have to manually change to use ext4 and it does default to 40 gig partition unless you change it

Right, in proposal settings area, I create LVM-based proposal, encrypt volume group, file system for root Ext4 (and disabled “enable snapshots” before changing option from BTRFS to Ext4 this time), propose separate home partition file system for home partition to Ext4 as well.

Now its giving me: 400.06MiB with ext4 for boot volume /dev/sda1
Create encrypted volume /dev/sda2 (931.12 GiB)
Create logical volume /dev/system/home (25.00 GiB) for /home with ext4
Create logical volume /dev/system/root (10.00 GiB) for / with ext4
Create swap logical volume /dev/system/swap (2.00 GiB)

I have 8GB ram, 1TB HDD… Shouldn’t /home, /, and swap be bigger in general though? What you suggest before I go through this again… I’ll wait on your response lmao.

That does not look right at all
the LVM is a container the other directories should go into it
Root is far too small also

2 gig swap is ok unless you do really memory intensive things you really do not need more

Well, when I go into expert partitioner, it lists them under “LV” type. Here’s what I see:

|FS Type
|Mount Point
|931.51 GiB
|400.06 MiB
||Linux native
|931.12 GiB
||lock icon/encrypt icon
|Linux LVM
|7.40 GiB
|3.69 MiB
|||EFI (FAT-12/16)
|4.32 GiB
|||Hidden HPFS/NTFS
|931.11 GiB
|||LVM2 system
|25.00 GiB
|10.00 GiB

|2.00 GiB

So, basically it looks right now, correct? Just now to resize the /home, /, maybe swap a little bit? I have written down a setup from before, was like this…

/home = 889.50 GB
/ = 40.00 GB
swap = 2.01 GB

There was a bunch of TMPFS created before as well though, three were 3.83 GB sized for:

Other two TMPFS were 784.49 MiB for:
/run/user/474 = 784.49 MiB
/run/user/1000 = 784.49 MiB

So basically it’s listing it right in expert partitioner right? Just need to resize some of those partitions to be bigger Lol.

Ok that looks better but the sizes of the logical LVM partitions are all wrong this can be set at install much easier then trying to change after the install. Just pay close attention to what the partition scheme page says and change any thing that is not the way you want it.

Yeah, I went into the expert partitioner then, and resized /home and / volumes. Gave:
/home = 889.50GB (the max allowed)
/ = 39.61GB (the max allowed)
swap = 2.00GB (Couldn’t make it any higher for some reason)

It did end up making 3 tmpfs directories though, 3.84GB in size each for the following:
/dev/shm = 3.84GB
/run = 3.84GB
/sys/fs/cgroup = 3.84GB

I’m not sure, but how to make the tmp empty on reboot? I tried finding info on it, but nothing seems to work…
Opened Open /etc/sysconfig/cron and nothing there for this line: CLEAR_TMP_DIRS_AT_BOOTUP=“no”

Tried opening and editing a file from a thread while back, and references to that line above there is said to be in another file instead, so I opened that other file to edit it, and it gives brown banner at top saying “New file” or whatever. So that other file that’s supposed to be edit, apparently doesn’t exist? Lol. Not sure what file controls this stuff now… Or maybe with Leap, it doesn’t need edited now it’s automatically handled every reboot?

/tmp should not be an issue if you have reasonable space. 10 gig is not reasonable space

You can’t use more space then you used for the LVM it is the container. There are no limits on the size except what you impose the with the LVM and the size of the drive. You can chain LVM’s and file systems together across drives. Remember you still need the boot partition out side the LVM to hold the kernel and related files, you can’t boot to a encrypted container

right, yeah. remember i didn’t keep the 10GB of course, I changed it to 39.61GB for there? lol. But yes, the other stuff you’re talking about makes sense… Thanks for explaining it. :wink: