could not update ICEauthority

Hi all can any one help me on booting in to gnome desktop i keep getting this could not update ICEauthority file /home/tip/.ICEauthority

Thanks
NWA2

change its permissions

chmod 644 /home/tip/.ICEauthority

or

chmod 777 /home/tip/.ICEauthority

Hi thanks for the quick reply and the help the chmod 777 fix the problem

Thanks
NWA2

You can also simply delete it. Worked for me.

+1

Setting that file “world readable” is the worst solution.

The normal settings are 0600 with owner=Your_username group=users.

So instead of chmod a “chown” is the way to go, if you don’t want to delete the file (as it sometimes gets stuck with owner:group = root:root).

777 = “The real number of the beast”.

:slight_smile:

and, my experience is that logging into the GUI/DE as root often
results in that file changing from owned by the user (whose /home it
is) to root…which is the SYMPTOM of the problem…

cure the problem by not logging into KDE, Gnome etc as root, and treat
the symptom by simply changing the ICEauthority ownership and access
back to the user, as gawd intended…

[but, we have folks here preaching it is alright to log in as root as
long as you are ‘careful’ and don’t do it often…]


natural_pilot

Thanks, microchip8 I had the same issue in

ICEauthority can’t update - openSUSE Forums

chmod 777
fixed my issue as well.

I’m still not sure how my issue came up in the first place, since I don’t remember logging into Gnome as root.

Hi, I have the same problem,but chmod 777 or chmod 644 doesn´t work. I’ve tried with chown but nothing.
What else can I do?
I’m new in suse.
Thanks for all.
have a nice day

I recommend to read this thread again. To me, the two most relevant comments here are:

and

I saw that problems with file .ICEauthority is very common.
So is there any plans to add similar instruction:

if exist .ICEauthority then
-----------------------------------
if error="error with accessing..." when try to acces .ICEauthority then
sudo chown...
counter=counter+1
if counter=(some value) then
show message "Something is wrong"
end if
end if
---------------------
else
touch .ICEauthority
end if 

into KDE/GNOME or script which is executed on start

The main cause of this problem is logging into the GUI as root. You should never do this. There is never a need to do this.

gogalthorp wrote:
> The main cause of this problem is logging into the GUI as root. You
> should never do this. There is never a need to do this.
>
>
agree, and would certainly NOT recommend anyone set up a script which
is designed to allow one to log into Gnome/KDE as root and then auto
repair the resulting damage…

because that .ICEauthority is absolutely NOT the only damage which may
occur…it is only one small part of the potential damage…

do NOT do it.


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

This happened to me after reinstalling to sort out issues with my kernel after a failed VMWare install.

Your solution worked for me perfectly and is the first time I used chown so happy with that too.

On 03/18/2011 12:36 PM, phrazer wrote:
>
> Your solution worked for me perfectly and is the first time I used
> chown so happy with that too.

that is not a solution, because it does not fix the problem, it only
hides the symptom of the problem

the problem is that something caused ICEauthority to not be usable…

and, that something has not had a bug logged against it…

in my experience, ICE* or Xauthority problems most often (maybe ONLY)
occur when someone logs into KDE/GNOME/LXDE or other desktop
environments as root…

to avoid the problem, just log in as yourself, a user, and then
“become root” as needed, using all the GUI or CLI tools you need by
following the instructions here:

http://en.opensuse.org/SDB:Login_as_root

do, that and i really doubt you will have another /.*authority problem…


DenverD
CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

Hi!

I have the same problem:
I get this error message at login

“Couldn’t update ICEauthority/home/name/ICEaithority.”

So, I deleted this - .ICEaithority

After that, the problem hasn’t gone. I get this message again at login “Couldn’t update ICEauthority/home/name/ICEaithority.”

And then I sudo in terminal, it rooting in home\username։

antranig@linux-plfp:~> su
Password:
linux-plfp:/home/antranig #

How can back to normal root?

And how to fix this problem: “Couldn’t update ICEauthority/home/name/ICEaithority.”?

First off see who owns that file and it’s permissions

Second if you become root in a console just type exit to log out of the session or close the console and then you are yourself again. Note you are only root inside that one session you don’t magically become root in all sessions. When you use su or related commands you are starting a new session with the permissions changed. any previous session that is running does not change it’s permissions

Generelly this happens if you log into a GUI as root. NEVER EVER log into a GUI as root. Bad things happen

I think the problems in this “if you log into a GUI as root”

I’ve tried to open a folder in Caja (like Nautilus in MATE desktop) clicked to right button to open in terminal.
I think the problem started after that.

Never ever log into a GUI as root There are several files in any normal users home that can be taken over by root ownership and stop the user from logging. Just DO NOT log in as root. becaome root from a normal user account via su sudo etc is fine log int a terminal as root fine NEVER log into a GUI as root. You will break things.

To fix it as root (not in a GUI logged as root) remove the file or fix the permissions.

OK.

So, I’ve removed “ICEauthority” file, but the message at the login “could not update ICEauthority” appears again, and the laptop works more slowly as before.

Check the permissions on other files and directories running as root can seriously mess up file permissions

Note that in your home that ICEauthority is a hidden file ie it has a period as fist letter ~/.ICEauthority

Note also that when fully root (su -) ~ points to the /root directory not the users /home directory, so you need to use full path names.