Could not start kdeinit4. check your installation

Hi - I just updated using zypper about an hour ago, and then KDE 4.2 started behaving strangely; it wouldn’t launch applications. I rebooted, and now on startup I get the message “Could not start kdeinit4. Check your installation.” Then I am dropped back into a login screen. I am writing this from gnome as KDE will not run.
Any ideas what broke in the update and how to fix it?

Thank you

From in gnome update all your kde4 packages. If you haven’t switched to the QT UI, it’s a bit tedious.
How To Get QT zypper GUI in GNOME YAST - openSUSE Forums

With the QT UI you can do Update all in this list Unconditionally. Do that in the kde4 repo’s

OK, I ran all the upgrades from the KDE 4.2 factory repo using the gnome UI in yast. (It was actually really intuitive - just filter for repo, choose the “upgrades” tab, select all, and hit “upgrade.”)
I actually prefer the gnome UI for yast - is there a way to get it in KDE?
Secondly - why wasn’t zypper giving me these upgrades? The KDE 4.2 factory build service repo is already pinned with a higher priority than the others - can I pin my repos differently so that this won’t happen again?

And by the way, another problem swiftly solved in minutes - thanks once again for your help!

Use “zypper dup” instead of “zypper up”, or run separate “zypper up libqt4” and confirm the vendor change.