Could not launch Root Terminal openSUSE 11.2

openSUSE 11.2, just installed.

When I start the “Root Terminal”, I get this error message:

Could not launch ‘Root Terminal’

Failed to execute child process “gksu” (No such file or directory)

This error message doesn’t mean enough to me to know what I need to do. Any ideas to get me started?


start a normal terminal and type:
sudo gnome-terminal

Ok, here is what appears, although I have no idea what it is telling me, I assume it is telling me that something aint right:

main2@linux-oynt:~$ sudo gnome-terminal
root’s password:
Failed to parse arguments: Cannot open display:

I figured out the problem.

“Root Terminal” is set up to run this command:

gksu /usr/bin/x-terminal-emulator

Well, two problems with that:

  1. There is no such file /usr/bin/x-terminal-emulator; and, more importantly,

  2. There is no gksu command in openSUSE 11.2.

I didn’t know that gksu was taken away. I wonder why.

Also, if gksu is taken away, and there will be no file /usr/bin/x-terminal-emulator, then why does the installation of openSUSE include the Root Terminal command? Just a mistake, I am assuming. But it left me wondering what the heck I had done wrong during the installation when the Root Terminal would not work.

What desktop does it come with? I don’t see it either (having KDE, Gnome and Xfce installed).

It must have been replaced by gnomesu and kdesu. Do you have any of those?

What about su -l in a terminal?

I currently see /usr/bin/x-terminal-emulator in Ubuntu/GNOME 9.10.

Yes, gnomesu worked for me in openSUSE 11.2.

su -l also worked in openSUSE 11.2. But when altering the menu item for Root Terminal, I used gnomesu to kick of the command.

dln9 wrote:
> I currently see /usr/bin/x-terminal-emulator in Ubuntu/GNOME 9.10.

[NOTE: i’m not sure how to fix your problem…however, i’m almost
certain i know what caused it, and i’d term the following as free
advice–feel free to ignore it, it is intended to be helpful in every way]

wait! are you telling me that you booted up openSUSE but can
“currently see” into the Ubuntu system partitions?

how do you do that? how many /usr partitions might you have mounted at
one time?

let me ask in a different way/thing: since i had never seen a single
other openSUSE/Gnome user not be able to launch a root terminal i
searched the entire web site looking for something
similar (using the “Failed to execute child process “gksu”” string,
see <>) and in every instance the user had
installed Synaptic/Apt…

i assume you have also, right?

and, you can sure do that if you want to–i mean it is your machine
and you can (and since you have the freedom to, maybe you should)
experiment all you want to…

but, in my most humble opinion and repeating you have every right to
try anything you wish: when you do unconventional things you should
expect unconventional/strange problems…and you should be willing to
do the study, research (and searches) to try to fix what your
experiments break, yourself…*

you know (i guess?) that “Linux is Linux” all are the same, except
very different…for several philosophical reasons…if you wanna
have a Linux distro based on Debian (using apt) there are plenty
available…plenty VERY good ones…but, my free advice is if you
use a distro born without the “Debian Way” of managing packages then
you ought to strive to learn the local Way (using RPM) and not try to
create a part RH part Deb Monster that you do not understand (and
neither do i) and can’t administer . . . you see what i mean?

sorry, i don’t know how to fix it, but i think it might begin by:

-don’t mount any Debian system partitions when booting openSUSE
-remove all Synaptic/Apt programs from your openSUSE partitions

unfortunately either of those may, at this point, result in an
inoperative system…therefore: -=good luck=- and let us know how you
sort it out…


Holy cow - I am so sorry to have been unclear in what I wrote.

What I meant is, I can see x-terminal-emulator in Ubuntu 9.10 that I have installed on a totally different machine.

I’m sorry to have caused you to write so much palladium, I do appreciate your interest and kindness. But I’m feeling guilty for having caused you to go to all that trouble.

Well, it is good advice, it is useful for others who may come across this who do in fact try what you are advising against.

So, in the openSUSE-only machine, I do not have synaptic, or any other Debian stuff installed. But, in the menu generated by the openSUSE installation - not by me - there is an item called “Root Terminal”, with this command: gksu /usr/bin/x-terminal-emulator, which is identical to the command for the menu item “Root Terminal” Ubuntu generated when it was installed on my (other) Ubuntu-dedicated machine. However, the menu item “Root Terminal” would never work for me in openSUSE, and I eventually figured out that in openSUSE in the way it installed itself there is not an x-terminal-emulator file, nor is there a gksu feature. And I think it is odd that there’d be this menu item for “Root Terminal” if the elements of the command no longer exist.

I changed the command for “Root Terminal” in openSUSE to

gnomesu /usr/bin/gnome-emulator

and it now works as expected.

dln9 wrote:
> But I’m feeling guilty for having caused you to go to all that
trouble… I do not have synaptic, or any
> other Debian stuff installed.

oops! sorry…NO problem, you shouldn’t feel guilty, at all! *

> I changed the command for “Root Terminal” in openSUSE to
> gnomesu /usr/bin/gnome-emulator … and it now works as expected.

was every 11.2 born with a “Root Terminal” which wouldn’t launch?
shouldn’t i find lots of folks asking why not?

maybe i should conclude that only one person tried to use Gnome :wink:

and when they couldn’t launch its root term, tried to learn why…

THANK YOU for that…now, i wonder if anyone has yet tried it in 11.3
M2 or logged a bug…and, ask you to, if it hasn’t been, see:


ok, I can do that

thanks…i really think that would be helpful…
(for one reason, i’m probably gonna go to Gnome/11.3)


Get a spare drive and install 11.3 M2 :wink:

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.3 Milestone 2 (i586) Kernel 2.6.33-rc7-3-default
up 2 days 5:03, 2 users, load average: 0.51, 0.16, 0.05
GPU GeForce 6600 TE/6200 TE - Driver Version: 195.36.03

malcolmlewis wrote:
> Get a spare drive and install 11.3 M2 :wink:

in fact, there is a new cuda es.2 just waiting right here for a

and, a 11.3M2 image…but, i can’t force my burner to burn…