Could not launch OBS on Wayland and GNOME, Slack dies on screen sharing, Flameshot can't shot

HI! There is the fresh Tumbleweed on GNOME with Wayland and I have multiple issues with screen recording and screen sharing. Some apps can’t even start without some “play around” (for example, OBS Studio), and others die on screen sharing (Slack installed with opi). I believe that’s the multiple symptoms of one problem.


╰─>$ obs                                                                                                                                                                                                                              16:27:35
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
qt.qpa.plugin: Could not find the Qt platform plugin "wayland" in ""
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

╰─>$ set QT_QPA_PLATFORM wayland; set XDG_SESSION_TYPE ""; obs                                                                                                                                                                        16:35:02
debug: Found portal inhibitor
debug: Attempted path: share/obs/obs-studio/locale/en-US.ini
debug: Attempted path: /usr/share/obs/obs-studio/locale/en-US.ini
debug: Attempted path: share/obs/obs-studio/locale.ini
debug: Attempted path: /usr/share/obs/obs-studio/locale.ini
debug: Attempted path: share/obs/obs-studio/themes/Yami.qss
debug: Attempted path: /usr/share/obs/obs-studio/themes/Yami.qss
info: Using EGL/X11
info: CPU Name: 11th Gen Intel(R) Core(TM) i7-1165G7 @ 2.80GHz
info: CPU Speed: 4447.215MHz
info: Physical Cores: 4, Logical Cores: 8
info: Physical Memory: 15225MB Total, 794MB Free
info: Kernel Version: Linux 6.2.12-1-default
info: Distribution: "openSUSE Tumbleweed" "20230503"
info: Session Type: 
info: Window System: X11.0 - vendor string: SUSE LINUX - vendor release: 12301001
info: Qt Version: 5.15.9 (runtime), 5.15.9 (compiled)
info: Portable mode: false
QMetaObject::connectSlotsByName: No matching signal for on_tbar_position_valueChanged(int)
info: OBS 29.0.2 (linux)

# Then normal start

Starting and working almost nicely until I try to share my screen. Then it throws this.

fish: Job 1, 'slack' terminated by signal SIGSEGV (Address boundary error)

Flameshot, if running from the menu, just doesn’t do any screenshots at all, and shows the message in the notification panel “Flameshot Error - Unable to capture the screen” only after I click exit.
But it does the screenshot if I run it from the terminal, what a heck.

@iromanyshyn Hi, see this page:

I use the GNOME built in screen recorder and the slack rpm (from slack), also I run X11 not wayland…