Could not install MP4 codecs for VLC


Newbie getting frustrated. Latest Tumbleweed.

Could not install MP4 codecs for VLC Tried everything from the forum. Yast is showing all the codec as installed. If I try to update, Yast crushes.

Parole also says the codec is missing, asks for download, when I click Install nothing happens.

Please help.


There are different variants of vlc (openSUSE packaged, Packman packaged, Videolan). Which variant are you using?

Did you try using the packman packaged vlc, together with vlc-codec (packaged also by packman) and change your system packages to packman (in YaST)? That typically works with the stable (15.1 , 15.2) variants of openSUSE so its worth trying with Tumbleweed I think.

Apologies - I assumed you know of the packman packaged repository? Possibly you don’t as a newbie.

Don’t install packman and videolan repos at the same time - as their packages are not always compatible with each other. I recommend only packman.

Further, I recommend you keep your repositories to a minimum - add and remove if/as required and don’t install a bunch and leave them installed - IMHO that will slow your updates and can lead to more confusion if/when troubles arise.

Worked. Changed vendor to Pacman. Thanks a lot for your prompt reply.

Excellent ! Thanks for sharing your solution.