"Could not initialize the browser's security component..."

I am sharing my Thunderbird profile between Vista and Suse 11.1 by putting my profile subdirectory on a FAT32 partition and pointing to this profile
from my profile.ini file in each OS.

So far this has worked pretty well for me.

I have discovered a problem when running Thunderbird When TB opens it gives me a message box which starts with “Could
not initialize the browser’s security component…” and the rest of the message offers suggestions why this is occuring.

None of the suggestions which I have found on the web for fixing this problem, after searching this error message with Google, are true for my situation, except perhaps the one about cert8.db being theoretically corrupted. However since there is no security problem under Vista, I heavily doubt this is the case, and I doubt whether my profile has been corrupted since again everything has been working properly under Vista for a while now.

I do notice that under Suse Linux 11.1 I have an OpenPGP menu item, which does not occur under Vista, and I suspect this may be the problem,
but I really don’t know for sure.

The problem manifests itself in not being able to send e-mail through a secure SMTP connection. I need this for a number of e-mail accounts I have, since my main ISP will block outgoing e-mail to another SMTP server if I do not send it via SSL, and these other e-mail accounts can not be used to send outgoing e-mail from my ISP’s SMTP server.

Does anyone have any idea how I can solve this problem ?

I do not want to change my TB profile location as I need to share my profile between OSs and I don’t have the patience to migrate all my current profile settings to another one on different OSs. I suspect this problem is not caused by the usual reasons as outlined at Could not initialize the browser security component - MozillaZine Knowledge Base
for example.

If anyone has any idea how to solve this it would be most appreciated as I do want to send outgoing e-mail under Suse.

Unfortunately I have no real solution for your browser, but I had the same error message repeatedly using seamonkey on 11.1 32bit. When I closed the browser and restarted, it would work the next time.

As for your problem sending email you could set up sendmail or postfix in connection with bind locally to send your messages directly to the recipient. There should be no real need to send mail via your ISP’s mail server as a smarthost. Your mail clients could then be configured to send outgoing messages to the SMTP port of localhost for delivery.

The problem was solved by removing all the Mozilla i586 rpms and installing all the necessary Mozilla x86_64 rpms for Thunderbird. Now there is no error message and sending e-mail from any account now works.