Could not get USB reconised_mucked up (KDE)

Hello All
The other day I wanted to check my camera’s photos and for a while I could not get it(USB) recognized til I figured that I need to go through " Configure Desktop". While trying I think I added ‘mount’ to a partition(Mint). Anyway I didn’t need to and now I have to confirm the mount with password every time I boot. Would someone be able to tell me where I can turn this off(unmount)? Thanks](

Did you add it to mount at boot?? is it encrypted???

Really need more info
Like when do you see this message???

look in /etc/fstab and see if that is were it is added.

My experience was that the KDE device notifier did not work at all well in 42.1. It is working fine in 42.2.

The device you show in the image appears to be reported as an internal SSD (Micron M600 device, /dev/sda2), so that would explain why root privileges (via polkit) are needed to access it. It is not a removable device as such, but check that it is not somehow listed in System Settings > Removable Devices

@ deano_ferrari;2806415, Thanks
Look here, nothing there. I just can’t remember where I changed to mount it at boot. It should’ve been obvious that it wasn’t the right thing to do.:embarrassed:](

thanks@ gogalthorp;2806401]
I must’ve added it to mount at boot. Thinking that that would help. It wasn’t the right drive anyway:shame: . Don’t think it is encrypted.
I see the message when the desktop is loaded, after boot.

UUID=fd0aaaab-fb1b-4c31-9bf2-a29427595e95 swap swap defaults 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 / btrfs defaults 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /boot/grub2/i386-pc btrfs subvol=@/boot/grub2/i386-pc 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /boot/grub2/x86_64-efi btrfs subvol=@/boot/grub2/x86_64-efi 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /opt btrfs subvol=@/opt 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /srv btrfs subvol=@/srv 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /tmp btrfs subvol=@/tmp 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /usr/local btrfs subvol=@/usr/local 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/crash btrfs subvol=@/var/crash 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/lib/libvirt/images btrfs subvol=@/var/lib/libvirt/images 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/lib/mailman btrfs subvol=@/var/lib/mailman 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/lib/mariadb btrfs subvol=@/var/lib/mariadb 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/lib/mysql btrfs subvol=@/var/lib/mysql 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/lib/named btrfs subvol=@/var/lib/named 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/lib/pgsql btrfs subvol=@/var/lib/pgsql 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/log btrfs subvol=@/var/log 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/opt btrfs subvol=@/var/opt 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/spool btrfs subvol=@/var/spool 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/tmp btrfs subvol=@/var/tmp 0 0
UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /.snapshots btrfs subvol=@/.snapshots 0 0
UUID=34C6-E029       /boot/efi            vfat       umask=0002,utf8=true  0 0
UUID=38b1d867-7fd6-4c2a-8e53-c6dba24d97af /home                xfs        defaults              1 2

that’s not a real issue
your device is recognized as an external hdd and root privileges are required to access it, you can use polkit to give all users write privileges to external partitions
that won’t auto-mount the device but dolphin (or any other file manager) won’t ask for root password when you do mount it

Yes, but as I pointed out ( and the OP now realises) the device concerned had nothing to do with the camera/external media.

Update; By configuring, Application Manu-settings-configuring desktop- removable devices, untick “Enable automatic mounting of removable devices” I have been able to stop the popup request for password.
It is not really removable media. It is the partition where Mint is. It means I cannot attach a usb without having to enter a password and/or undo the tick again.
It feels it isn’t quite right yet?

Yes, probably a bug report is required to get that fixed. Following a quick search, I did find a bug report describing similar behaviour here.

Some users have found that they have a BIOS setting to enable/disable hot-plugging of certain storage devices which then causes them to be detected as removable or not.

If you execute the following

udisksctl info -b /dev/sda2

you’ll probably get output showing that it is flagged as a removable device

MediaRemovable:                     true

A udev rule targeting the problem device could be used to set the environment flag ‘ENV{UDISKS_SYSTEM_INTERNAL}=“1”’, but better to get it fixed properly IMO.

FWIW, I don’t usually use “Enable automatic mounting of removable devices”, but just use the notifier to mount external media when needed. I have Dolphin configured to show the devices available, so that can also be used to ‘mount on demand’.

This opensuse bug report mentions that it has now been fixed as of kernel 4.5…

The stable kernel switched to 4.5, and it contains the fix for this problem:
ata: ahci: don’t mark HotPlugCapable Ports as external/removable

Please reopen if the issue is still seen with 4.5 kernel. Thanks.

thanks @ deano_ferrari;2806472]

gde@linux-raih:~> udisksctl info -b /dev/sda2
    Configuration:              ]
    CryptoBackingDevice:        '/'
    Device:                     /dev/sda2
    DeviceNumber:               2050
    Drive:                      '/org/freedesktop/UDisks2/drives/Micron_M600_MTFD_15240FC54CFA'
    HintAuto:                   false
    HintIgnore:                 false
    HintPartitionable:          true
    HintSystem:                 true
    Id:                         by-id-ata-Micron_M600_MTFDDAK256MBF_15240FC54CFA-part2
    IdType:                     ext4
    IdUUID:                     0dfdedd2-b5d4-4a3b-837b-562f44952a5f
    IdUsage:                    filesystem
    IdVersion:                  1.0
    MDRaid:                     '/'
    MDRaidMember:               '/'
    PreferredDevice:            /dev/sda2
    ReadOnly:                   false
    Size:                       41943040000
    Symlinks:                   /dev/disk/by-id/ata-Micron_M600_MTFDDAK256MBF_15240FC54CFA-part2
    Flags:              0                                                                                                                                                                                                                                                      
    IsContained:        false                                                                                                                                                                                                                                                  
    IsContainer:        false                                                                                                                                                                                                                                                  
    Number:             2                                                                                                                                                                                                                                                      
    Offset:             537919488                                                                                                                                                                                                                                              
    Size:               41943040000                                                                                                                                                                                                                                            
    Table:              '/org/freedesktop/UDisks2/block_devices/sda'                                                                                                                                                                                                           
    Type:               0fc63daf-8483-4772-8e79-3d69d8477de4                                                                                                                                                                                                                   
    UUID:               1f4dce86-4c0d-4ec7-871e-97e391fc4afc                                                                                                                                                                                                                   

Ok, the udisksctl output does not report it as removable device which is strange, so I’m not sure why it is treated as such.

Over the next 24hrs or so I will have a few more reboots and try the settings in the removable devices.

Did you check your UEFI/BIOS for hotplugging options?

Would I go for that to the bios settings at boot?

Yes, you can access it via particular key combo at boot.

Haven’t seen that setting in bios](

A simple udev rule might also work eg /etc/udev/rules.d/20-udisk-ignore.rules


A better rule might match on unique device path instead. You can get that using

find /sys/devices/ -name sda2

For example, I get


so rule could be

DEVPATH=="/sys/devices/pci0000:00/0000:00:0d.0/ata1/host0/target0:0:0/0:0:0:0/block/sda/sda2", ENV{UDISKS_IGNORE}="1" 

or for whole sda device

DEVPATH=="/sys/devices/pci0000:00/0000:00:0d.0/ata1/host0/target0:0:0/0:0:0:0/block/sda", ENV{UDISKS_IGNORE}="1" 

I’ll be sweating soon! :wink:

de@linux-raih:~> find /sys/devices/ -name sda2

Didn’t realise you’re up in Auckland. Hello from the Mainland!!
Nice to see a local!